Bug 219776

Summary: [GTK][WPE] Async overflow scrolling is disabled by default due to brokenness
Product: WebKit Reporter: Chris Lord <clord>
Component: ScrollingAssignee: Chris Lord <clord>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, cgarcia, cmarcelo, ews-watchlist, fred.wang, Hironori.Fujii, jamesr, kondapallykalyan, luiz, psaavedra, simon.fraser, thorton, tonikitoo, webkit-bug-importer, zan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Chris Lord 2020-12-11 03:37:18 PST
Sorry for the slightly vague title - Currently, AsyncOverflowScrollingEnabled is disabled in WebPreferencesInternal for Nicosia because enabling it results in broken rendering on scrolled overflow scrolling layers and their descendents. This is obviously less than ideal, scrolling is often not done on the root frame and disabling async overflow scrolling causes us to fall back to both main-thread scrolling and results in more painting and worse-feeling scrolling.

The bug appears to be boundsOrigin on layers not being respected correctly. We should fix this and enable this setting - I have a patch that fixes at least the most obvious issues. I'm not certain it's a complete fix, but we need wider testing to identify further issues.

In the future, it'd probably be ideal for there to be more shared code here between Mac and Linux, where Mac has a complete and likely more bug-free implementation. I think it'd be good to do some consolidation/refactoring and renaming in this code path - though this patch is quite small, it took a long time to figure out.
Comment 1 Chris Lord 2020-12-11 03:42:51 PST
Created attachment 415986 [details]
Patch
Comment 2 Chris Lord 2020-12-11 07:04:10 PST
*** Bug 203412 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lord 2020-12-11 09:13:24 PST
Created attachment 416000 [details]
Patch
Comment 4 EWS 2020-12-11 09:50:35 PST
Committed r270683: <https://trac.webkit.org/changeset/270683>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 416000 [details].
Comment 5 Radar WebKit Bug Importer 2020-12-11 09:51:16 PST
<rdar://problem/72226809>