Bug 219008

Summary: REGRESSION (r269598): [ Mac ] imported/w3c/web-platform-tests/html/semantics/embedded-content/the-iframe-element/iframe-network-error.sub.html is flaky failing
Product: WebKit Reporter: Truitt Savell <tsavell>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Truitt Savell 2020-11-16 16:11:29 PST
imported/w3c/web-platform-tests/html/semantics/embedded-content/the-iframe-element/iframe-network-error.sub.html

This test is failing flakily on Mac. 

History:
https://results.webkit.org/?suite=layout-tests&test=webgpu%2Fwhlsl%2Fdont-crash-parsing-enum.html

Diff:
--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/embedded-content/the-iframe-element/iframe-network-error.sub-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/embedded-content/the-iframe-element/iframe-network-error.sub-actual.txt
@@ -1,6 +1,6 @@
+Blocked access to external URL http://nonexistent.localhost/
 Blocked access to external URL http://nonexistent.localhost/
 CONSOLE MESSAGE: Refused to display 'http://localhost:8800/html/semantics/embedded-content/resources/not-embeddable.html' in a frame because it set 'X-Frame-Options' to 'deny'.
-Blocked access to external URL http://nonexistent.localhost/
 CONSOLE MESSAGE: Refused to display 'http://localhost:8800/html/semantics/embedded-content/resources/not-embeddable.html' in a frame because it set 'X-Frame-Options' to 'deny'.
 
 
I am able to reproduce this test using command:
run-webkit-tests --iterations 2000 --exit-after-n-failures 1 --exit-after-n-crashes-or-timeouts 1 --debug-rwt-logging --no-retry --force --no-build -f imported/w3c/web-platform-tests/html/semantics/embedded-content/the-iframe-element/iframe-network-error.sub.html
Comment 1 Radar WebKit Bug Importer 2020-11-16 16:11:49 PST
<rdar://problem/71463894>
Comment 2 Truitt Savell 2020-11-16 16:40:24 PST
I am able to reproduce this on a checkout of r269598 but not a checkout of r269597
Comment 3 Truitt Savell 2020-11-16 16:41:02 PST
Looks like this was a resin of tests. should we just mark this test as failing?
Comment 4 Chris Dumez 2020-11-18 14:35:21 PST
Committed r269987: <https://trac.webkit.org/changeset/269987>