Bug 217105

Summary: Enable the Web Share Level 2 feature wherever Web Share is enabled
Product: WebKit Reporter: Tim Horton <thorton>
Component: New BugsAssignee: Tim Horton <thorton>
Status: RESOLVED FIXED    
Severity: Normal CC: aestes, bdakin, megan_gardner, nicolas, nirmal.dhan94, rigel, rodrigoschneider94, webkit-bug-importer, wenson_hsieh
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Tim Horton 2020-09-29 13:45:48 PDT
Enable the Web Share Level 2 feature wherever Web Share is enabled
Comment 1 Tim Horton 2020-09-29 13:46:12 PDT
Created attachment 410042 [details]
Patch
Comment 2 Radar WebKit Bug Importer 2020-09-29 13:49:02 PDT
<rdar://problem/69762176>
Comment 3 EWS 2020-09-29 14:41:55 PDT
Committed r267762: <https://trac.webkit.org/changeset/267762>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 410042 [details].
Comment 4 Tim Horton 2020-09-29 14:43:40 PDT
*** Bug 217091 has been marked as a duplicate of this bug. ***
Comment 5 rigel 2020-11-18 14:35:30 PST
As of iOS 14.3 beta 2, this flag still seems to be disabled by default.
Comment 6 Tim Horton 2020-11-18 15:15:55 PST
(In reply to rigel from comment #5)
> As of iOS 14.3 beta 2, this flag still seems to be disabled by default.

Correct
Comment 7 rigel 2020-11-18 16:06:20 PST
Thanks for clarifying, I wasn't sure if it was just my device. After your patch was landed (thank you!), I have checked each beta release for its inclusion. Is there anything missing for this to work?
Comment 8 Tim Horton 2020-11-18 16:12:49 PST
(In reply to rigel from comment #7)
> Thanks for clarifying, I wasn't sure if it was just my device. After your
> patch was landed (thank you!), I have checked each beta release for its
> inclusion. Is there anything missing for this to work?

No, but the timing from changes landing in WebKit to showing up in a version of iOS is not guaranteed, nor does Apple comment on it.
Comment 9 Nirmal 2021-06-08 12:54:06 PDT
Looks like this is finally enabled by default in iOS 15, at least in the first dev beta.
Comment 10 Tim Horton 2021-06-08 13:06:31 PDT
(In reply to Nirmal from comment #9)
> Looks like this is finally enabled by default in iOS 15, at least in the
> first dev beta.

Yes! Please test it out and file any bugs you run into.