Bug 216361

Summary: [GTK] REGRESSION(r266815): Several GTK API tests are timing out
Product: WebKit Reporter: Diego Pino <dpino>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aperez, bburg, bugs-noreply, cgarcia, drousso, ews-watchlist, pangle
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=216138
Attachments:
Description Flags
Patch aperez: review+

Description Diego Pino 2020-09-10 07:15:20 PDT
The following GTK-API tests are failing after r266815:

Unexpected timeouts (3)
    /WebKit2Gtk/TestInspector
        /webkit/WebKitWebInspector/custom-container-destroyed
        /webkit/WebKitWebInspector/manual-attach-detach
        /webkit/WebKitWebInspector/default
Comment 1 Diego Pino 2020-09-10 07:18:22 PDT
See: https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Tests%29/builds/15753/steps/API%20tests/logs/stdio

TEST: /app/webkit/Tools/glib/../../WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestInspector...
  /webkit/WebKitWebInspector/default:                                 TIMEOUT
GLib-GIO-DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
resource:///org/webkit/inspector/UserInterface/Main.js:16766: CONSOLE JS ERROR SyntaxError: Unexpected keyword 'let'. Expected ';' after variable declaration.
resource:///org/webkit/inspector/UserInterface/Main.html:38:11: CONSOLE JS ERROR ReferenceError: Can't find variable: WI
  /webkit/WebKitWebInspector/manual-attach-detach:                    TIMEOUT
GLib-GIO-DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
GLib-DEBUG: posix_spawn avoided (child_setup specified) 
resource:///org/webkit/inspector/UserInterface/Main.js:16766: CONSOLE JS ERROR SyntaxError: Unexpected keyword 'let'. Expected ';' after variable declaration.
resource:///org/webkit/inspector/UserInterface/Main.html:38:11: CONSOLE JS ERROR ReferenceError: Can't find variable: WI
Comment 2 Carlos Garcia Campos 2020-09-11 04:55:46 PDT
Created attachment 408526 [details]
Patch
Comment 3 Adrian Perez 2020-09-11 06:03:11 PDT
Comment on attachment 408526 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=408526&action=review

> Source/WebInspectorUI/UserInterface/Views/DOMNodeDetailsSidebarPanel.js:357
> +            let identifier = `${options.identifier ?? title}-event-listener-section`;

I wonder how was the debugging session which arrived at this… just, wow!
Comment 4 Carlos Garcia Campos 2020-09-11 07:01:02 PDT
It was easy because the error message was pretty clear and we already had the revision that introduced the bug :-)
Comment 5 BJ Burg 2020-09-11 23:52:24 PDT
Thanks for investigating, Carlos!
Comment 6 Carlos Garcia Campos 2020-09-12 00:09:17 PDT
Committed r266975: <https://trac.webkit.org/changeset/266975>