Bug 216307

Summary: Uncaught Exception: TypeError: null is not an object (evaluating 'this.listItemElement.classList')
Product: WebKit Reporter: Antoine Quint <graouts>
Component: Web InspectorAssignee: Nikita Vasilyev <nvasilyev>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, drousso, ews-watchlist, inspector-bugzilla-changes, nvasilyev, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
URL: https://ionicframework.com/docs
Attachments:
Description Flags
Patch none

Description Antoine Quint 2020-09-09 04:58:10 PDT
Uncaught Exception in Web Inspector with a ToT build.

Steps to Reproduce:
1. Go to https://ionicframework.com/docs and open the Web Inspector
2. In the iOS device on the right of the page, scroll down to "Modal" and click on that row
3. Click on the "Open Modal" button

Uncaught Exceptions:
-----------------------
 - TypeError: null is not an object (evaluating 'this.listItemElement.classList') (at DOMTreeElement.js:1449:41)
    _nodeTitleInfo @ DOMTreeElement.js:1449:41
    updateTitle @ DOMTreeElement.js:1314:55
    _updateModifiedNodes @ DOMTreeUpdater.js:128:46
    ? @ DOMTreeUpdater.js:53:34
    _execute @ Debouncer.js:132:29
    ? @ Debouncer.js:86:26
-----------------------

Notes:
Inspected URL:        https://ionicframework.com/docs
Loading completed:    true
Frontend User Agent:  Mozilla/5.0 (Macintosh; Intel Mac OS X 11_0) AppleWebKit/605.1.15 (KHTML, like Gecko)
Comment 1 Radar WebKit Bug Importer 2020-09-09 04:58:26 PDT
<rdar://problem/68565824>
Comment 2 Nikita Vasilyev 2020-09-23 16:47:11 PDT
In 2016, there was a very similar uncaught exception:
Bug 162123 - Uncaught Exception: null is not an object (evaluating 'this.listItemElement.classList')
Comment 3 Nikita Vasilyev 2020-09-24 16:37:01 PDT
Created attachment 409633 [details]
Patch
Comment 4 Nikita Vasilyev 2020-09-24 16:37:38 PDT
(In reply to Nikita Vasilyev from comment #3)
> Created attachment 409633 [details]
> Patch

This is essentially the same fix as in "Bug 162123 - Uncaught Exception: null is not an object (evaluating 'this.listItemElement.classList')" from 2016.
Comment 5 Nikita Vasilyev 2020-09-24 16:40:37 PDT
A couple of hours ago I was able to reproduce this on http://jsbin.testim.io/geg/11. However, I can't reproduce it on that page now :/

The steps from Antoine still work reliably.
Comment 6 BJ Burg 2020-09-25 10:26:31 PDT
Comment on attachment 409633 [details]
Patch

r=me
Comment 7 EWS 2020-09-25 10:42:31 PDT
Committed r267577: <https://trac.webkit.org/changeset/267577>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 409633 [details].