Bug 216180

Summary: [Webauthn] YubiKey 5 NFC gesture not recognized when userVerification is 'required'
Product: WebKit Reporter: Andrii Sych <duwoka>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: jiewen_tan, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: iPhone / iPad   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 181943    

Description Andrii Sych 2020-09-04 08:40:10 PDT
During iOS 14 Beta 7 (18A5357e) testing with YubiKey 5 NFC I found Client PIN is only asked in certain conditions.

I was using https://webauthn.io for testing:

Attestation type: Direct
Authenticator Type: Cross platform
User Verification: Required
Register with Resident Key: Required

When I try to register, NFC gesture is ignored and key prompt is only cancellable, no matter if Client PIN is pre-installed on token or not.

If I change User Verification to 'Preferred', NFC gesture is recognized and PIN is asked both during registration and authentication only if Client PIN was pre-installed on token, otherwise is never asked.
Comment 1 Radar WebKit Bug Importer 2020-09-04 09:36:21 PDT
<rdar://problem/68350577>
Comment 2 Jiewen Tan 2020-09-13 23:35:01 PDT

*** This bug has been marked as a duplicate of bug 215836 ***