Bug 215634

Summary: Rename replaceAllChildren to replaceAllChildrenWithNewText
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: New BugsAssignee: Ryosuke Niwa <rniwa>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, changseok, darin, esprehn+autocc, ews-watchlist, gyuyoung.kim, kangil.han, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 215600    
Bug Blocks:    
Attachments:
Description Flags
Renamed the function
none
Updated per Darin's comment darin: review+

Ryosuke Niwa
Reported 2020-08-18 17:32:27 PDT
Rename replaceAllChildren to replaceAllChildrenWithNewText
Attachments
Renamed the function (5.09 KB, patch)
2020-08-18 17:36 PDT, Ryosuke Niwa
no flags
Updated per Darin's comment (5.04 KB, patch)
2020-08-18 18:08 PDT, Ryosuke Niwa
darin: review+
Ryosuke Niwa
Comment 1 2020-08-18 17:36:51 PDT
Created attachment 406825 [details] Renamed the function
Darin Adler
Comment 2 2020-08-18 17:38:04 PDT
Comment on attachment 406825 [details] Renamed the function View in context: https://bugs.webkit.org/attachment.cgi?id=406825&action=review > Source/WebCore/dom/ContainerNode.h:62 > + void replaceAllChildrenWithNewText(Ref<Text>&&); Why not just take a String instead of requiring the caller make the text node?
Ryosuke Niwa
Comment 3 2020-08-18 17:38:31 PDT
(In reply to Darin Adler from comment #2) > Comment on attachment 406825 [details] > Renamed the function > > View in context: > https://bugs.webkit.org/attachment.cgi?id=406825&action=review > > > Source/WebCore/dom/ContainerNode.h:62 > > + void replaceAllChildrenWithNewText(Ref<Text>&&); > > Why not just take a String instead of requiring the caller make the text > node? That's a good point. Let's just do that.
Darin Adler
Comment 4 2020-08-18 17:38:49 PDT
Comment on attachment 406825 [details] Renamed the function View in context: https://bugs.webkit.org/attachment.cgi?id=406825&action=review > Source/WebCore/dom/ContainerNode.cpp:635 > // This function assumes the input node is not a DocumentFragment and is parentless to decrease complexity. I realized that there is one call site that *wishes* it could use this for DocumentFragment.
Ryosuke Niwa
Comment 5 2020-08-18 17:41:34 PDT
(In reply to Darin Adler from comment #4) > Comment on attachment 406825 [details] > Renamed the function > > View in context: > https://bugs.webkit.org/attachment.cgi?id=406825&action=review > > > Source/WebCore/dom/ContainerNode.cpp:635 > > // This function assumes the input node is not a DocumentFragment and is parentless to decrease complexity. > > I realized that there is one call site that *wishes* it could use this for > DocumentFragment. Yeah but now that I think about it more, that just needs a separate function.
Ryosuke Niwa
Comment 6 2020-08-18 18:08:49 PDT
Created attachment 406827 [details] Updated per Darin's comment
Ryosuke Niwa
Comment 7 2020-08-18 18:28:58 PDT
Radar WebKit Bug Importer
Comment 8 2020-08-18 18:29:13 PDT
Note You need to log in before you can comment on or make changes to this bug.