Bug 215025

Summary: ASSERTION FAILURE: WebKit::AuthenticationManager::initializeConnection(IPC::Connection *)_block_invoke
Product: WebKit Reporter: Hector Lopez <hector_i_lopez>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: tsavell, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Hector Lopez 2020-07-31 11:12:24 PDT
imported/w3c/web-platform-tests/webrtc/RTCSctpTransport-maxChannels.html

This test is a constant crash according to history on iOS Simulator wk2 Debug. This appears to start from r264918 which is a change for https://bugs.webkit.org/show_bug.cgi?id=214661. Which references may be fallout from  https://trac.webkit.org/changeset/264492/webkit.

History:
https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fwebrtc%2FRTCSctpTransport-maxChannels.html&platform=ios&style=debug&limit=50000

Crash Log:
No crash log found for WebKitTestRunnerApp:42502.

stdout:

stderr:


#
# Fatal error in: /Volumes/Data/slave/ios-simulator-13-debug/build/Source/ThirdParty/libwebrtc/Source/webrtc/call/rtp_demuxer.cc, line 49
# last system error: 316
# Check failed: sink_by_mid_.empty()
# #CRASHED - com.apple.WebKit.WebContent.Development (pid 50294)
LEAK: 1 WebProcessPool
LEAK: 2 WebPageProxy
Comment 1 Hector Lopez 2020-07-31 11:21:05 PDT
Created attachment 405711 [details]
Patch
Comment 2 EWS 2020-07-31 11:57:13 PDT
Committed r265153: <https://trac.webkit.org/changeset/265153>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 405711 [details].
Comment 3 Radar WebKit Bug Importer 2020-07-31 11:58:22 PDT
<rdar://problem/66391947>
Comment 4 Hector Lopez 2020-08-17 19:38:04 PDT
Test is now a flaky crash on iOS wk2 Debug.

Crash log:

worker/1 imported/w3c/web-platform-tests/webrtc/RTCSctpTransport-maxChannels.html crashed, (stderr lines):
17:56:07.345 13903   
17:56:07.345 13903   
17:56:07.345 13903   #
17:56:07.345 13903   # Fatal error in: /Volumes/Data/slave/ios-simulator-13-debug/build/Source/ThirdParty/libwebrtc/Source/webrtc/call/rtp_demuxer.cc, line 49
17:56:07.346 13903   # last system error: 316
17:56:07.346 13903   # Check failed: sink_by_mid_.empty()
17:56:07.346 13903   # #CRASHED - com.apple.WebKit.WebContent.Development (pid 21911)
17:56:07.346 13903   LEAK: 1 WebProcessPool
17:56:07.346 13903   LEAK: 1 WebPageProxy
17:56:07.346 13903   ASSERTION FAILED: isMainThread()
17:56:07.346 13903   /Volumes/Data/slave/ios-simulator-13-debug/build/Source/WebKit/Shared/Authentication/cocoa/AuthenticationManagerCocoa.mm(53) : virtual void WebKit::AuthenticationManager::initializeConnection(IPC::Connection *)_block_invoke

Expectation changed:
https://trac.webkit.org/changeset/265807/webkit
Comment 5 youenn fablet 2020-08-18 00:22:02 PDT

*** This bug has been marked as a duplicate of bug 214661 ***