Bug 21175

Summary: Store the callee CodeBlock, not the caller CodeBlock, in the call frame header
Product: WebKit Reporter: Geoffrey Garen <ggaren>
Component: JavaScriptCoreAssignee: Geoffrey Garen <ggaren>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Attachments:
Description Flags
patch ggaren: review+

Description Geoffrey Garen 2008-09-27 09:53:05 PDT
Patch coming.
Comment 1 Geoffrey Garen 2008-09-27 09:53:27 PDT
Created attachment 23877 [details]
patch
Comment 2 Geoffrey Garen 2008-09-27 09:57:18 PDT
Forgot to mention in ChangeLog:

        Small regression in bytecode, because currently every op_ret reads the
        callee CodeBlock to check needsFullScopeChain, and bytecode does not
        keep "r" in a register. On-balance, this is probably OK, since CTI is
        our high-performance execution model. Also, this should go away once
        we make needsFullScopeChain statically determinable at parse time.

Comment 3 Cameron Zwarich (cpst) 2008-09-27 10:14:28 PDT
Comment on attachment 23877 [details]
patch

r=me
Comment 4 Geoffrey Garen 2008-09-27 10:16:10 PDT
Comment on attachment 23877 [details]
patch

r+ based on Cameron's comment.
Comment 5 Geoffrey Garen 2008-09-27 10:27:58 PDT
http://trac.webkit.org/changeset/36997