Bug 21115

Summary: REGRESSION (r34702): Safari no longer zips bundled documents
Product: WebKit Reporter: Darin Adler <darin>
Component: FormsAssignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Normal Keywords: InRadar
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 25879    
Attachments:
Description Flags
patch adele: review+

Description Darin Adler 2008-09-25 12:10:45 PDT
This feature got broken somewhere along the line.
Comment 1 Darin Adler 2008-09-25 12:11:08 PDT
<rdar://problem/6245773>
Comment 2 Darin Adler 2008-09-25 12:12:35 PDT
Created attachment 23814 [details]
patch
Comment 3 Darin Adler 2008-09-25 13:02:30 PDT
http://trac.webkit.org/changeset/36903
Comment 4 Eric Seidel (no email) 2009-05-21 00:34:04 PDT
Looks like this regressed again, see bug 25879.  At least we can make automated tests for this now with bug 25852 resolved!
Comment 5 Mark Rowe (bdash) 2009-05-21 00:54:35 PDT
This didn't regress.  Eric misunderstood how this works.
Comment 6 Eric Seidel (no email) 2009-05-21 00:56:55 PDT
What Mark means is that the ChromeClient gets to decide.  The Safari client only decides to handle package files.  bug 25879 is related, but not the same bug, as it's about handling directories in <input> elements.  We accept the drop of a directory and then fail to handle it.  We should either not accept the drop or handle them if we accept them. :)