Bug 210655

Summary: REGRESSION: (r260243) [ Mac and iOS ] imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html fails.
Product: WebKit Reporter: Jason Lawrence <Lawrence.j>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aakash_jain, ap, shvaikalesh, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Mac   
OS: macOS 10.15   
See Also: https://bugs.webkit.org/show_bug.cgi?id=203288

Description Jason Lawrence 2020-04-17 08:30:12 PDT
imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html

Description:
This test is failing on all platforms, styles and flavors. The test was passing consistently until r260242, but it regressed with r260243.

History:
https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fcss%2Fcssom-view%2FMediaQueryList-addListener-handleEvent.html&limit=50000

Diff:
--- /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent-actual.txt
@@ -1,4 +1,4 @@
-CONSOLE MESSAGE: line 102: [object Object]
+CONSOLE MESSAGE: [object Object]
 CONSOLE MESSAGE: TypeError: 'handleEvent' property of event listener should be callable
 CONSOLE MESSAGE: TypeError: 'handleEvent' property of event listener should be callable
Comment 1 Radar WebKit Bug Importer 2020-04-17 08:30:35 PDT
<rdar://problem/61936044>
Comment 2 Jason Lawrence 2020-04-17 08:32:31 PDT
I am able to reproduce this issue with r260243, but cannot reproduce it with r260241. 

r260243:
run-webkit-tests --iterations 99 --exit-after-n-failures 3 --force -f imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html

[4/99] imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html failed unexpectedly (text diff)
[5/99] imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html failed unexpectedly (text diff)
[6/99] imported/w3c/web-platform-tests/css/cssom-view/MediaQueryList-addListener-handleEvent.html failed unexpectedly (text diff)
Exiting early after 3 failures. 3 tests run.
0 tests ran as expected, 3 didn't (96 didn't run):

r260241:
All 99 tests ran as expected.
Comment 3 Alexey Proskuryakov 2020-04-17 12:44:02 PDT
Jason updated the expectation in http://trac.webkit.org/r260256, which is I think all that's needed here.

Aakash, this got tested by EWS before the change that removed line numbers, and landed a week after EWS.