Bug 210165

Summary: [ Catalina wk2 ] webrtc/peer-connection-audio-mute2.html is flaky timing out.
Product: WebKit Reporter: Jason Lawrence <Lawrence.j>
Component: WebRTCAssignee: Nobody <webkit-unassigned>
Status: RESOLVED CONFIGURATION CHANGED    
Severity: Normal CC: webkit-bot-watchers-bugzilla, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Mac   
OS: macOS 10.15   

Description Jason Lawrence 2020-04-07 16:14:36 PDT
webrtc/peer-connection-audio-mute2.html

Description:
This test is flaky timing out on Catalina wk2. The test flaky times out occasionally, with the oldest timeout on 3/12/2020 after consistently passing for a period of time. There is also a single failure that's less than two weeks old.

History:
https://results.webkit.org/?suite=layout-tests&test=webrtc%2Fpeer-connection-audio-mute2.html&version_name=Catalina&limit=50000&style=release&style=debug&flavor=wk2&flavor=wk1&recent=false

Diff: 
--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/webrtc/peer-connection-audio-mute2-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/webrtc/peer-connection-audio-mute2-actual.txt
@@ -1,3 +1,5 @@
+#PID UNRESPONSIVE - WebKitTestRunner (pid 72547)
+FAIL: Timed out waiting for notifyDone to be called
 
-PASS Muting and unmuting a local audio track 
-
+#EOF
+#EOF
Comment 1 Radar WebKit Bug Importer 2020-04-07 16:14:53 PDT
<rdar://problem/61415785>
Comment 2 Jason Lawrence 2020-04-07 16:26:08 PDT
I have marked this test as flaky timing out and failing while this issue is investigated.
https://trac.webkit.org/changeset/259684/webkit
Comment 3 Jason Lawrence 2020-04-07 17:01:47 PDT
I was able to reproduce the failure on r259672 by running too many child processes, but I cannot reproduce the timeout with iterations or a test list.
Comment 4 Jason Lawrence 2020-05-13 09:22:49 PDT
This test appears to be passing consistently now. I have removed the expectations here: https://trac.webkit.org/changeset/261618/webkit