Bug 207953

Summary: [ Mac wk2 Release ] fast/scrolling/latching/scroll-iframe-in-overflow.html is flaky failing.
Product: WebKit Reporter: Jason Lawrence <Lawrence.j>
Component: ScrollingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: simon.fraser, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Mac   
OS: macOS 10.15   

Description Jason Lawrence 2020-02-19 11:30:00 PST
fast/scrolling/latching/scroll-iframe-in-overflow.html

Description:
This test is flaky failing on Mac wk2 Release.

History:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fscrolling%2Flatching%2Fscroll-iframe-in-overflow.html&style=release&flavor=wk2

Diff:
--- /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/fast/scrolling/latching/scroll-iframe-in-overflow-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk2/build/layout-test-results/fast/scrolling/latching/scroll-iframe-in-overflow-actual.txt
@@ -1,2 +1,2 @@
-PASS The iframe scrolled but the wrapper did not.
+FAIL The iframe's scroll position is: 0, and the wrapper's scroll position is: 0
Comment 1 Radar WebKit Bug Importer 2020-02-19 11:30:22 PST
<rdar://problem/59598663>
Comment 2 Jason Lawrence 2020-02-19 11:32:58 PST
The oldest failure on the dashboard, r255128, has the same diff.
Comment 3 Jason Lawrence 2020-02-19 11:37:27 PST
I have marked this test as failing while this issue is investigated.
https://trac.webkit.org/changeset/256929/webkit
Comment 4 Jason Lawrence 2020-02-19 11:40:26 PST
Correction: the oldest failure that I see on the dashboard is on r251655. I am not able to locate a diff for that failure.
Comment 5 Jason Lawrence 2020-02-19 13:59:31 PST
I was able to reproduce this issue using r256933 with the command below.
run-webkit-tests fast/scrolling/latching/scroll-iframe-in-overflow.html --iterations 4000 --exit-after-n-failures 5 -f --force

[3391/4000] fast/scrolling/latching/scroll-iframe-in-overflow.html failed unexpectedly (text diff)
Retrying 1 unexpected failure ...
Running 1 WebKitTestRunner.
3999 tests ran as expected, 1 didn't:
Comment 6 Simon Fraser (smfr) 2020-03-21 11:58:44 PDT
No longer flakey. Expectation removed in r258701.

*** This bug has been marked as a duplicate of bug 197819 ***