Bug 207642

Summary: [ macOS ] inspector/runtime/getCollectionEntries.html is flaky failing
Product: WebKit Reporter: Jacob Uphoff <jacob_uphoff>
Component: CanvasAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: darin, dino, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Jacob Uphoff 2020-02-12 10:02:31 PST
inspector/runtime/getCollectionEntries.html is flaky failing 

This test has been a flaky failure and a flaky timeout for all visible history.

I ran the test on Catalina wk2 debug x5000 and was able to reproduce the failure one time.

History:

https://results.webkit.org/?suite=layout-tests&test=fast%2Fcanvas%2Fwebgl%2FtexImage2D-mse-flipY-false.html&limit=50000

Diff:

--- /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/fast/canvas/webgl/texImage2D-mse-flipY-false-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/fast/canvas/webgl/texImage2D-mse-flipY-false-actual.txt
@@ -1,6 +1,6 @@
 Setting video src.
 Video can play.
 Checking the canvas pixels.
-PASS: Bottom edge is red.
-PASS: Top edge is blue.
+FAIL: Bottom edge is not red.
+FAIL: Top edge is not blue.
Comment 1 Radar WebKit Bug Importer 2020-02-12 10:02:51 PST
<rdar://problem/59390577>
Comment 2 Ryan Haddad 2020-02-13 13:20:26 PST
This test appears to have been flaky since it was added in https://trac.webkit.org/changeset/250087/webkit

Here is the correct history link:
https://results.webkit.org/?limit=50000&platform=mac&recent=false&suite=layout-tests&test=inspector%2Fruntime%2FgetCollectionEntries.html
Comment 3 Darin Adler 2020-03-14 13:56:01 PDT
The text above is about a different test. I am going to consolidate this with an earlier report about the same test.

*** This bug has been marked as a duplicate of bug 207463 ***