Bug 207385

Summary: http/tests/paymentrequest/page-cache-completed-payment-response.https.html is flaky failing.
Product: WebKit Reporter: Jason Lawrence <Lawrence.j>
Component: Tools / TestsAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: aestes, cdumez, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Mac   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Jason Lawrence 2020-02-07 08:33:10 PST
http/tests/paymentrequest/page-cache-completed-payment-response.https.html

Description:
This test is flaky failing on Mac wk2.

History:
https://results.webkit.org/?platform=ios&platform=mac&suite=layout-tests&test=http%2Ftests%2Fpaymentrequest%2Fpage-cache-completed-payment-response.https.html

Diff:
--- /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/http/tests/paymentrequest/page-cache-completed-payment-response.https-expected.txt
+++ /Volumes/Data/slave/catalina-debug-tests-wk2/build/layout-test-results/http/tests/paymentrequest/page-cache-completed-payment-response.https-actual.txt
@@ -9,9 +9,10 @@
 pageshow - from cache
 PASS Page did enter and was restored from the back/forward cache
 Testing that PaymentResponse remains in the Completed state.
-PASS response.complete() rejected promise  with InvalidStateError: The object is in an invalid state..
-PASS response.retry() rejected promise  with InvalidStateError: The object is in an invalid state..
+FAIL response.complete() should reject promise with InvalidStateError. Rejected with AbortError instead.
+FAIL response.retry() should reject promise with InvalidStateError. Rejected with AbortError instead.
 PASS successfullyParsed is true
+Some tests failed.
 
 TEST COMPLETE
Comment 1 Jason Lawrence 2020-02-07 08:36:11 PST
I was able to reproduce this issue with the following command:
run-webkit-tests http/tests/paymentrequest/page-cache-completed-payment-response.https.html --iterations 5000

260 tests ran as expected, 13 didn't (4727 didn't run):
Comment 2 Radar WebKit Bug Importer 2020-02-07 08:36:37 PST
<rdar://problem/59260167>
Comment 3 Jason Lawrence 2020-02-07 09:32:01 PST
I have adjusted the expectations for this test, so it will now pass on failure while this is being investigated. 
https://trac.webkit.org/changeset/256025/webkit
Comment 4 Alexey Proskuryakov 2020-02-08 14:42:17 PST
This is a test for "PaymentRequest / PaymentResponse should not prevent entering the back/forward cache".
Comment 5 Chris Dumez 2020-03-12 16:55:15 PDT
Committed r258373: <https://trac.webkit.org/changeset/258373>
Comment 6 Jason Lawrence 2020-03-24 11:17:15 PDT
It looks like this issue is still occurring on Mac wk2 Debug. The diff has changed slightly.

History: 
https://results.webkit.org/?platform=mac&suite=layout-tests&test=http%2Ftests%2Fpaymentrequest%2Fpage-cache-completed-payment-response.https.html&style=debug

Diff:
--- /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/http/tests/paymentrequest/page-cache-completed-payment-response.https-expected.txt
+++ /Volumes/Data/slave/mojave-debug-tests-wk2/build/layout-test-results/http/tests/paymentrequest/page-cache-completed-payment-response.https-actual.txt
@@ -9,8 +9,8 @@
 pageshow - from cache
 PASS Page did enter and was restored from the back/forward cache
 Testing that PaymentResponse remains in the Completed state.
-PASS response.complete() rejected promise  with InvalidStateError: The object is in an invalid state..
-PASS response.retry() rejected promise  with InvalidStateError: The object is in an invalid state..
+PASS response.complete() rejected promise  with AbortError: The operation was aborted..
+PASS response.retry() rejected promise  with AbortError: The operation was aborted..
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 7 Chris Dumez 2020-04-23 09:56:32 PDT
Created attachment 397351 [details]
Patch
Comment 8 EWS 2020-04-23 10:26:19 PDT
Committed r260579: <https://trac.webkit.org/changeset/260579>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 397351 [details].