Bug 20572

Summary: Window doesn't get Animation/Transition events unless document is listening
Product: WebKit Reporter: Dean Jackson <dino>
Component: DOMAssignee: Dean Jackson <dino>
Status: RESOLVED FIXED    
Severity: Normal CC: simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Bug Depends on: 20571    
Bug Blocks:    
Attachments:
Description Flags
makes sure Window registers event types hyatt: review+

Description Dean Jackson 2008-08-29 19:21:53 PDT
We have code that intercepts event listener registration on the document level to make sure we don't fire unnecessary transition and animation events.  However, if a listener is only on the window it means the event will never fire.
Comment 1 Simon Fraser (smfr) 2008-11-20 18:09:09 PST
Should the window even get animation events? Is there precedence?
Comment 2 Dean Jackson 2008-12-04 16:21:00 PST
I did a little research and it seems the window should get these events. However, this is the first time one of the "noisy" events makes sense to be added to the window (others like mutation events aren't turned on). The problem is that the document doesn't register the event type when adding an event listener to the window, the way event target does. It's an easy fix.
Comment 3 Dean Jackson 2008-12-04 16:22:07 PST
Created attachment 25756 [details]
makes sure Window registers event types
Comment 4 Dave Hyatt 2008-12-05 09:53:04 PST
Comment on attachment 25756 [details]
makes sure Window registers event types

r=me
Comment 5 Dean Jackson 2008-12-05 11:01:35 PST
Committed r39037
	M	WebCore/dom/Document.cpp
	M	WebCore/ChangeLog
	M	LayoutTests/ChangeLog
	M	LayoutTests/transitions/transition-end-event-window.html