Bug 205306

Summary: ANGLE: Fix last WebGL conformance regressions
Product: WebKit Reporter: James Darpinian <jdarpinian>
Component: ANGLEAssignee: James Darpinian <jdarpinian>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, cdumez, commit-queue, dino, esprehn+autocc, ews-watchlist, graouts, gyuyoung.kim, justin_fan, kbr, kondapallykalyan, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 198948    
Attachments:
Description Flags
ANGLE: Fix last WebGL conformance regressions
none
Fix missing Reviewed by line in ChangeLog none

Description James Darpinian 2019-12-16 15:16:06 PST
ANGLE: Fix last WebGL conformance regressions
Comment 1 James Darpinian 2019-12-16 15:19:41 PST
Created attachment 385815 [details]
ANGLE: Fix last WebGL conformance regressions
Comment 2 Kenneth Russell 2019-12-16 16:07:54 PST
Fantastic work James! Could you add a comment here with the names of the tests that are now fixed?
Comment 3 James Darpinian 2019-12-16 16:20:11 PST
non-ascii-comments.vert.html for the non-ascii comments fix. For the alpha:false antialias:true fix, I don't have a list of the fixed tests, it was a bunch of random ones that just happened to use that combination.
Comment 4 Justin Fan 2019-12-17 13:18:52 PST
r=me! I've pinged Dean since I'm not an official reviewer.
Comment 5 WebKit Commit Bot 2019-12-17 15:18:34 PST
Comment on attachment 385815 [details]
ANGLE: Fix last WebGL conformance regressions

Rejecting attachment 385815 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-03', 'validate-changelog', '--check-oops', '--non-interactive', 385815, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

/Volumes/Data/EWS/WebKit/Source/WebCore/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: https://webkit-queues.webkit.org/results/13292616
Comment 6 James Darpinian 2019-12-17 16:34:30 PST
Created attachment 385928 [details]
Fix missing Reviewed by line in ChangeLog
Comment 7 James Darpinian 2019-12-17 16:35:39 PST
Sorry, I accidentally removed the "Reviewed by" line in my changelog.
Comment 8 WebKit Commit Bot 2019-12-19 12:04:21 PST
Comment on attachment 385928 [details]
Fix missing Reviewed by line in ChangeLog

Clearing flags on attachment: 385928

Committed r253779: <https://trac.webkit.org/changeset/253779>
Comment 9 WebKit Commit Bot 2019-12-19 12:04:23 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2019-12-19 12:05:49 PST
<rdar://problem/58087484>