Bug 205194

Summary: [JSC] Remove ArrayBufferNeuteringWatchpointSet
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: JavaScriptCoreAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: alecflett, annulen, beidson, benjamin, cdumez, cmarcelo, dbates, ews-watchlist, gyuyoung.kim, jsbell, keith_miller, mark.lam, msaboff, ryuan.choi, saam, sergio, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch
none
Patch
none
Patch
none
Patch
none
Patch saam: review+

Yusuke Suzuki
Reported 2019-12-12 20:16:12 PST
I think, just putting RefPtr<WatchpointSet> in ArrayBuffer is enough.
Attachments
Patch (68.00 KB, patch)
2019-12-13 16:30 PST, Yusuke Suzuki
no flags
Patch (68.49 KB, patch)
2019-12-13 16:51 PST, Yusuke Suzuki
no flags
Patch (70.08 KB, patch)
2019-12-13 17:00 PST, Yusuke Suzuki
no flags
Patch (70.24 KB, patch)
2019-12-13 17:14 PST, Yusuke Suzuki
no flags
Patch (72.45 KB, patch)
2019-12-13 17:53 PST, Yusuke Suzuki
no flags
Patch (72.47 KB, patch)
2019-12-13 18:05 PST, Yusuke Suzuki
no flags
Patch (70.76 KB, patch)
2019-12-13 21:02 PST, Yusuke Suzuki
no flags
Patch (73.39 KB, patch)
2019-12-13 21:27 PST, Yusuke Suzuki
saam: review+
Yusuke Suzuki
Comment 1 2019-12-12 20:16:53 PST
By reordering ArrayBuffer's field, we can save 8bytes. We can put RefPtr<WatchpointSet> in this place.
Yusuke Suzuki
Comment 2 2019-12-13 16:03:06 PST
This is the last patch, after that, all non-object non-butterfly JSCells are in IsoSubspace.
Yusuke Suzuki
Comment 3 2019-12-13 16:30:06 PST
Yusuke Suzuki
Comment 4 2019-12-13 16:51:00 PST
Yusuke Suzuki
Comment 5 2019-12-13 17:00:25 PST
Yusuke Suzuki
Comment 6 2019-12-13 17:14:21 PST
Yusuke Suzuki
Comment 7 2019-12-13 17:53:26 PST
Yusuke Suzuki
Comment 8 2019-12-13 18:05:08 PST
Yusuke Suzuki
Comment 9 2019-12-13 21:02:02 PST
Yusuke Suzuki
Comment 10 2019-12-13 21:27:51 PST
Saam Barati
Comment 11 2019-12-16 12:28:36 PST
Comment on attachment 385678 [details] Patch r=me
Saam Barati
Comment 12 2019-12-16 12:29:02 PST
Comment on attachment 385678 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=385678&action=review > Source/JavaScriptCore/runtime/ArrayBuffer.cpp:387 > + m_neuteringWatchpointSet.fireAll(vm, "Array buffer was neutered"); is it worth keeping this in notifyIncommingReferencesOfTransfer?
Yusuke Suzuki
Comment 13 2019-12-16 14:16:04 PST
Comment on attachment 385678 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=385678&action=review >> Source/JavaScriptCore/runtime/ArrayBuffer.cpp:387 >> + m_neuteringWatchpointSet.fireAll(vm, "Array buffer was neutered"); > > is it worth keeping this in notifyIncommingReferencesOfTransfer? Renamed it to `notifyNeutering` and add this firing into `notifyNeutering` method :)
Yusuke Suzuki
Comment 14 2019-12-16 14:17:36 PST
Radar WebKit Bug Importer
Comment 15 2019-12-16 14:18:18 PST
Note You need to log in before you can comment on or make changes to this bug.