Bug 20451

Summary: Inspector doesn't auto scroll when selecting text
Product: WebKit Reporter: Gavin Sherlock <gsherloc>
Component: Web Inspector (Deprecated)Assignee: Maxime Britto <maxime.britto>
Status: RESOLVED FIXED    
Severity: Normal CC: maxime.britto
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Gavin Sherlock 2008-08-19 15:09:51 PDT
Steps to reproduce:

1.  Go to a url
2.  Right click and Inspect Element for anything on the page
3.  In the Inspector, Select Resources, and click on a resource (can be js or html, or some other text file)
4.  Select text in the resource, and drag beyond the bottom of the window

Expected results:

Window will scroll, so text off screen will be selected too.

Actual results:

No scrolling occurs.

Tested in r35814 on 10.5.4 on a MacPro.
Comment 1 Timothy Hatcher 2008-08-19 15:41:56 PDT
I think this is a regression caused by r35244.
Comment 2 Maxime Britto 2008-08-20 18:53:08 PDT
I don't think the bug is related to r35244, I've looked into it and it seems that according to the mouse eventm the first node under the mouse is the HTML node from the whole inspector, instead of the text node included in the current displayed ressource div.
Comment 3 Maxime Britto 2008-08-21 12:13:00 PDT
<rdar://problem/6166435>
Comment 4 Timothy Hatcher 2008-08-22 13:44:40 PDT
Fixed in r35882.