Bug 20420

Summary: text repainting does not account for glyphs which draw outside the typographic bounds of the font
Product: WebKit Reporter: James Deering <james>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Major CC: mitz, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
URL: http://www.deerring.com
Attachments:
Description Flags
reduced test case
none
reduced test case (with better instructions) none

Description James Deering 2008-08-17 14:39:18 PDT
SVG fonts with opacity do not display properly. Displays only partial font display. See Menu rollovers and page graphics for examples.
Comment 1 Eric Seidel (no email) 2008-10-04 00:19:08 PDT
Computing Text rects incorrectly, thus invalidating wrong region on mouseover

I'm working on a reduction.
Comment 2 Eric Seidel (no email) 2008-10-04 00:44:25 PDT
Created attachment 24085 [details]
reduced test case
Comment 3 Eric Seidel (no email) 2008-10-04 00:46:51 PDT
Created attachment 24086 [details]
reduced test case (with better instructions)
Comment 4 mitz 2008-10-04 01:07:28 PDT
I think this is just a duplicate of bug 6274.
Comment 5 Eric Seidel (no email) 2008-10-04 01:15:45 PDT
Agreed.  This is a dupe of bug 6274.  However James could work around bug 6274 by specifying a decent value on the font.  Unfortunately due to bug 21365 (which will likely be fixed in about an hour!) to support old nightlies would require putting the descent value on the <font> element instead of the <font-face> element. :)

*** This bug has been marked as a duplicate of 6274 ***