Bug 203966

Summary: REGRESSION (r252161): 3 transitions/ tests time-out
Product: WebKit Reporter: Truitt Savell <tsavell>
Component: Tools / TestsAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: dino, simon.fraser, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=202489
Attachments:
Description Flags
Patch dino: review+

Description Truitt Savell 2019-11-07 09:59:47 PST
It looks like the changes in r252161 caused 3 tests to time out on Mac and iOS:

transitions/multiple-shadow-transitions.html 
transitions/cubic-bezier-overflow-shadow.html 
legacy-animation-engine/transitions/cubic-bezier-overflow-shadow.html

I was able to reproduce these timeouts using command:

run-webkit-tests transitions/multiple-shadow-transitions.html transitions/cubic-bezier-overflow-shadow.html legacy-animation-engine/transitions/cubic-bezier-overflow-shadow.html --iterations 20 -f

They reproduce on r252161 but not r252160.
Comment 1 Radar WebKit Bug Importer 2019-11-07 10:00:52 PST
<rdar://problem/56986342>
Comment 2 Simon Fraser (smfr) 2019-11-07 11:40:18 PST
Created attachment 383064 [details]
Patch
Comment 3 Simon Fraser (smfr) 2019-11-07 13:08:52 PST
https://trac.webkit.org/changeset/252203/webkit