Bug 201817

Summary: [GTK] webkitgtk dark theme
Product: WebKit Reporter: Ivo Dordic <ivo.dordic>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: bugs-noreply, mcatanzaro
Priority: P3 Keywords: Gtk
Version: WebKit Nightly Build   
Hardware: PC   
OS: Linux   

Description Ivo Dordic 2019-09-16 01:08:05 PDT
This is probably related to bugs 165072 and 186219, if so please remove this.

I'm running Cinnamon with dark theme on Arch.
After upgrading webkit2gtk arch version 2.24.4-1 to latest stable webkit2gtk, arch version 2.26.0-1 I can no longer see HTML formatted messages preview in Evolution mail client. When I select content from preview window I can see the content. I have tried various cinnamon dark themes and the problem seems to exist with each one of them, also tried generating dark themes with oomox. It works normal with light themes or text based messages, but not HTML formatted ones.
Other reports on Arch bug tracker confirm the same thing happens on Gnome DE.
It's also been reported that the bug is affecting websites that don't specify text color, usually those with black text on white outside of gnome environment.

https://bugs.archlinux.org/task/63714?project=1&string=webkit2gtk
Comment 1 Michael Catanzaro 2019-12-23 10:10:35 PST

*** This bug has been marked as a duplicate of bug 202194 ***