Bug 20162

Summary: Web Inspector does not update the DOM tree when attributes change
Product: WebKit Reporter: Timothy Hatcher <timothy@apple.com>
Component: Web Inspector (Deprecated)Assignee: Kelly Norton <knorton@google.com>
Status: RESOLVED FIXED    
Severity: Normal CC: dieter@komendera.com, emacemac7@mac.com, farukates@me.com, knorton@google.com, rik@webkit.org, timothy@apple.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 8191    
Bug Blocks:    
Attachments:
Description Flags
Uses the new direct callbacks from WebCore timothy: review+, timothy: commit‑queue-

Description From 2008-07-24 11:07:10 PST
With the fix for bug 6590 we now update the DOM tree for element insertion and removal. But attributes changes do not update in the inspector. This is blocked by bug 8191.
------- Comment #1 From 2009-04-11 18:29:34 PST -------
*** Bug 25103 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2010-01-13 18:44:50 PST -------
Created an attachment (id=46534) [details]
Uses the new direct callbacks from WebCore

I don't see any significant change in dromaeo runs with this change:

With Change:
http://dromaeo.com/?id=85714
http://dromaeo.com/?id=85717

Without Change:
http://dromaeo.com/?id=85721
http://dromaeo.com/?id=85722
------- Comment #3 From 2010-01-13 19:26:57 PST -------
(From update of attachment 46534 [details])
> +        var event = { target : node };

This should be: {target: node}


> +    _attributesUpdated : function(event)

There should be no space before the ":".
------- Comment #4 From 2010-01-13 19:49:51 PST -------
http://trac.webkit.org/changeset/53232