Bug 200520

Summary: Web Inspector: rename `queryObjects` to `queryInstances` for clarity
Product: WebKit Reporter: Devin Rousso <drousso>
Component: Web InspectorAssignee: Devin Rousso <drousso>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, drousso, ews-watchlist, inspector-bugzilla-changes, joepeck, keith_miller, mark.lam, msaboff, nvasilyev, rniwa, sbarati, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on: 176766    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Archive of layout-test-results from ews101 for mac-highsierra
none
Archive of layout-test-results from ews114 for mac-highsierra
none
Patch none

Description Devin Rousso 2019-08-07 15:55:23 PDT
`Objects` could really refer to anything, whereas `Instances` is MUCH clearer and more self explanatory.

We should still keep an "alias" from `queryObjects` to `queryInstances` so that existing users aren't affected.
Comment 1 Devin Rousso 2019-08-07 15:59:54 PDT
Created attachment 375760 [details]
Patch
Comment 2 Nikita Vasilyev 2019-08-07 16:04:51 PDT
Do the other browsers (*cough cough* Chromium) plan to rename queryObjects as well? It does seem like a better name.
Comment 3 Devin Rousso 2019-08-07 16:07:38 PDT
(In reply to Nikita Vasilyev from comment #2)
> Do the other browsers (*cough cough* Chromium) plan to rename queryObjects as well? It does seem like a better name.
Not that I'm aware.  This is another reason why I'm keeping an alias :P
Comment 4 EWS Watchlist 2019-08-07 17:08:44 PDT Comment hidden (obsolete)
Comment 5 EWS Watchlist 2019-08-07 17:08:46 PDT Comment hidden (obsolete)
Comment 6 EWS Watchlist 2019-08-07 17:58:08 PDT Comment hidden (obsolete)
Comment 7 EWS Watchlist 2019-08-07 17:58:10 PDT Comment hidden (obsolete)
Comment 8 Devin Rousso 2019-08-07 19:39:35 PDT
Created attachment 375780 [details]
Patch
Comment 9 Brian Burg 2019-08-08 11:09:37 PDT
Comment on attachment 375780 [details]
Patch

r=me
Comment 10 WebKit Commit Bot 2019-08-08 11:59:10 PDT
Comment on attachment 375780 [details]
Patch

Clearing flags on attachment: 375780

Committed r248434: <https://trac.webkit.org/changeset/248434>
Comment 11 WebKit Commit Bot 2019-08-08 11:59:12 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Radar WebKit Bug Importer 2019-08-08 12:00:26 PDT
<rdar://problem/54090116>