Bug 198762

Summary: Web Inspector: Network: replace CFNetwork SPI with new API where able
Product: WebKit Reporter: Devin Rousso <drousso>
Component: Web InspectorAssignee: Devin Rousso <drousso>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: achristensen, benjamin, cdumez, cmarcelo, commit-queue, dbates, drousso, ews-watchlist, inspector-bugzilla-changes, joepeck, ryanhaddad, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch
none
Archive of layout-test-results from ews114 for mac-highsierra none

Comment 1 Devin Rousso 2019-06-11 13:58:01 PDT
Created attachment 371875 [details]
Patch
Comment 2 EWS Watchlist 2019-06-11 15:59:47 PDT Comment hidden (obsolete)
Comment 3 EWS Watchlist 2019-06-11 15:59:49 PDT Comment hidden (obsolete)
Comment 4 EWS Watchlist 2019-06-11 16:18:47 PDT Comment hidden (obsolete)
Comment 5 WebKit Commit Bot 2019-06-19 17:14:05 PDT
Comment on attachment 371875 [details]
Patch

Clearing flags on attachment: 371875

Committed r246616: <https://trac.webkit.org/changeset/246616>
Comment 6 WebKit Commit Bot 2019-06-19 17:14:07 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2019-06-19 17:15:57 PDT
<rdar://problem/51921158>
Comment 8 Ryan Haddad 2019-07-03 11:11:25 PDT
Reverted r246616 for reason:

Caused http/tests/inspector/network/har/har-page.html to fail on Catalina.

Committed r247095: <https://trac.webkit.org/changeset/247095>
Comment 9 Alex Christensen 2019-10-11 11:13:40 PDT
I'm implementing this in https://bugs.webkit.org/show_bug.cgi?id=202825 because I was unaware this bug existed when I started.
Comment 10 Joseph Pecoraro 2019-10-11 13:36:57 PDT
Marking as a duplicate than.

*** This bug has been marked as a duplicate of bug 202825 ***