Bug 198418

Summary: REGRESSION(r244182): [CoordinatedGraphics] Related view doesn't receive graphic updates
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, magomez, zan
Priority: P2 Keywords: Gtk
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=177484
Attachments:
Description Flags
Patch zan: review+

Description Carlos Garcia Campos 2019-05-31 05:28:24 PDT
This is because we need a DisplayRefreshMonitor per drawing area, but the one from the first ThreradedCompositor is always reused because they use the same display ID.
Comment 1 Carlos Garcia Campos 2019-05-31 05:32:38 PDT
Created attachment 371051 [details]
Patch
Comment 2 Zan Dobersek 2019-05-31 06:17:52 PDT
Comment on attachment 371051 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=371051&action=review

> Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/DrawingAreaCoordinatedGraphics.cpp:549
> +    m_webPage.windowScreenDidChange(std::numeric_limits<uint32_t>::max() - m_webPage.pageID().toUInt64());

If you can find a better way to make that page ID into a 32-bit, then go ahead.
Comment 3 Carlos Garcia Campos 2019-05-31 06:23:53 PDT
(In reply to Zan Dobersek from comment #2)
> Comment on attachment 371051 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=371051&action=review
> 
> > Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/DrawingAreaCoordinatedGraphics.cpp:549
> > +    m_webPage.windowScreenDidChange(std::numeric_limits<uint32_t>::max() - m_webPage.pageID().toUInt64());
> 
> If you can find a better way to make that page ID into a 32-bit, then go
> ahead.

I'm following the same approach as mac port.
Comment 4 Carlos Garcia Campos 2019-06-03 01:07:12 PDT
Committed r246030: <https://trac.webkit.org/changeset/246030>