Bug 196953

Summary: Web Inspector: DOM Nodes should not show $0 when selected in Console area
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, drousso, inspector-bugzilla-changes, joepeck, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[IMAGE] Before
none
[IMAGE] After
none
[PATCH] Proposed Fix none

Description Joseph Pecoraro 2019-04-15 20:02:30 PDT
DOM Nodes should not show $0 when selected in Console area
Comment 1 Joseph Pecoraro 2019-04-15 20:03:25 PDT
Steps to Reproduce:
1. Log an element to the console
2. Click the element
  => the "= $0" overlaps the "= $1"
  => it isn't really the $0
Comment 2 Joseph Pecoraro 2019-04-15 20:13:39 PDT
Created attachment 367489 [details]
[IMAGE] Before
Comment 3 Joseph Pecoraro 2019-04-15 20:13:50 PDT
Created attachment 367490 [details]
[IMAGE] After
Comment 4 Joseph Pecoraro 2019-04-15 20:16:15 PDT
Created attachment 367491 [details]
[PATCH] Proposed Fix
Comment 5 Devin Rousso 2019-04-15 23:30:07 PDT
Comment on attachment 367491 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=367491&action=review

rs=me

> Source/WebInspectorUI/ChangeLog:13
> +        Make parameters explicit. Drop "selectable" which was always true.

It may be worth mentioning (or this comment can suffice) that there were other creators of `WI.DOMTreeOutline`, but due to the fact that `WI.TreeOutline`'s constructor has a default `selectable = true`, passing `undefined` as all three arguments in those cases would fall back to the default `true`, so yes, it was always `true`.

> Source/WebInspectorUI/UserInterface/Views/DOMTreeContentView.js:66
> +        this._domTreeOutline = new WI.DOMTreeOutline({omitRootDOMNode: true, excludeRevealElementContextMenu: true, showLastSelected: true});

Nice!
Comment 6 WebKit Commit Bot 2019-04-15 23:57:21 PDT
Comment on attachment 367491 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 367491

Committed r244327: <https://trac.webkit.org/changeset/244327>
Comment 7 WebKit Commit Bot 2019-04-15 23:57:23 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2019-04-15 23:58:22 PDT
<rdar://problem/49931793>