Bug 196196

Summary: [GTK] Regression in inspector/audit/run-resources.html
Product: WebKit Reporter: Diego Pino <dpino>
Component: New BugsAssignee: Diego Pino <dpino>
Status: RESOLVED FIXED    
Severity: Normal CC: clord, drousso, ews-watchlist, joepeck, pangle, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Diego Pino 2019-03-25 03:07:59 PDT
The test is failing since the introduction of this feature in r242941 (Web Inspector: Audit: provide a way to get the contents of resources https://bugs.webkit.org/show_bug.cgi?id=195266).

It seems the problem is that in the GTK port there's an extra assert print.

Diff:

--- /WebKit/WebKitBuild/Release/layout-test-results/inspector/audit/run-resources-expected.txt
+++ /WebKit/WebKitBuild/Release/layout-test-results/inspector/audit/run-resources-actual.txt
@@ -13,6 +13,7 @@
 PASS: sample-resource.css should have the expected content.
 PASS: sample-resource.css should not be base64 encoded.
 Found sample-resource.js.
+ASSERT: sample-resource.js should have a text/javascript MIME type.
 PASS: sample-resource.js should have the expected content.
 PASS: sample-resource.js should not be base64 encoded.
Comment 1 Diego Pino 2022-01-05 00:23:21 PST
Created attachment 448363 [details]
Patch
Comment 2 Chris Lord 2022-01-07 08:12:56 PST
Comment on attachment 448363 [details]
Patch

LGTM.
Comment 3 EWS 2022-01-07 09:28:31 PST
Committed r287752 (245815@main): <https://commits.webkit.org/245815@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 448363 [details].
Comment 4 Radar WebKit Bug Importer 2022-01-07 09:29:25 PST
<rdar://problem/87256140>