Summary: | Make sure to correctly notify of end of a ServiceWorkerJob when the context is stopped | ||||||||
---|---|---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | youenn fablet <youennf> | ||||||
Component: | Service Workers | Assignee: | youenn fablet <youennf> | ||||||
Status: | RESOLVED FIXED | ||||||||
Severity: | Normal | CC: | achristensen, cdumez, commit-queue, webkit-bug-importer | ||||||
Priority: | P2 | Keywords: | InRadar | ||||||
Version: | WebKit Nightly Build | ||||||||
Hardware: | Unspecified | ||||||||
OS: | Unspecified | ||||||||
Attachments: |
|
Description
youenn fablet
2019-02-28 17:07:22 PST
Created attachment 363279 [details]
Patch
Comment on attachment 363279 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=363279&action=review > Source/WebCore/ChangeLog:3 > + Make sure to correctly notify of end of job when the context is stopped This title should mention ServiceWorkerJob. Otherwise it's way too vague. > Source/WebCore/ChangeLog:14 > + Covered by existing tests not crashing anymore, in particular imported/w3c/web-platform-tests/service-workers/service-worker/skip-waiting.https.html. Should we unskip this test? > Source/WebCore/workers/service/ServiceWorkerJob.cpp:-172 > - if (!m_scriptLoader) Why can this no longer be null? (In reply to Alex Christensen from comment #2) > Comment on attachment 363279 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=363279&action=review > > > Source/WebCore/ChangeLog:3 > > + Make sure to correctly notify of end of job when the context is stopped > > This title should mention ServiceWorkerJob. Otherwise it's way too vague. > > > Source/WebCore/ChangeLog:14 > > + Covered by existing tests not crashing anymore, in particular imported/w3c/web-platform-tests/service-workers/service-worker/skip-waiting.https.html. > > Should we unskip this test? > > > Source/WebCore/workers/service/ServiceWorkerJob.cpp:-172 > > - if (!m_scriptLoader) > > Why can this no longer be null? > > > Source/WebCore/ChangeLog:3 > > > + Make sure to correctly notify of end of job when the context is stopped > > > > This title should mention ServiceWorkerJob. Otherwise it's way too vague. OK > > > Source/WebCore/ChangeLog:14 > > > + Covered by existing tests not crashing anymore, in particular imported/w3c/web-platform-tests/service-workers/service-worker/skip-waiting.https.html. > > > > Should we unskip this test? It is unskilled but crashes in debug sometimes. > > > Source/WebCore/workers/service/ServiceWorkerJob.cpp:-172 > > > - if (!m_scriptLoader) > > > > Why can this no longer be null? It is called in one place and we check for this before calling this method. Comment on attachment 363279 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=363279&action=review > Source/WebCore/workers/service/ServiceWorkerContainer.h:151 > + uint64_t m_ongoingSettledRegistrationCount { 0 }; Bad name, when I saw it I was wondering why you needed this member and did not rely on m_ongoingSettledRegistrations.size() instead. We probably want to call it m_lastOngoingSettledRegistrationIdentifier, like the data member above. Created attachment 363352 [details]
Patch
Comment on attachment 363352 [details] Patch Clearing flags on attachment: 363352 Committed r242372: <https://trac.webkit.org/changeset/242372> All reviewed patches have been landed. Closing bug. |