Bug 193829

Summary: [iOS] Rename some WebKit-internal functions and variables that reference "data interaction"
Product: WebKit Reporter: Wenson Hsieh <wenson_hsieh>
Component: HTML EditingAssignee: Wenson Hsieh <wenson_hsieh>
Status: RESOLVED FIXED    
Severity: Normal CC: aestes, bdakin, commit-queue, megan_gardner, thorton, wenson_hsieh
Priority: P2 Keywords: DoNotImportToRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Wenson Hsieh 2019-01-25 10:34:00 PST
Regrettably, parts of our API (technically, SPI) surface still contain "dataInteraction" in the name. However, we should at least rename all methods internal to WebKit to not use this obfuscated terminology.
Comment 1 Wenson Hsieh 2019-01-25 10:42:34 PST
Created attachment 360122 [details]
Patch
Comment 2 Tim Horton 2019-01-25 11:03:57 PST
Comment on attachment 360122 [details]
Patch

rs=me
Comment 3 WebKit Commit Bot 2019-01-25 11:45:14 PST
Comment on attachment 360122 [details]
Patch

Clearing flags on attachment: 360122

Committed r240491: <https://trac.webkit.org/changeset/240491>
Comment 4 WebKit Commit Bot 2019-01-25 11:45:15 PST
All reviewed patches have been landed.  Closing bug.