Bug 192051

Summary: Flaky Test: webgl/2.0.0/conformance/more/functions/bindBuffer.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: justin_fan, lforschler, ryanhaddad, tsavell
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from webkit-cq-03 none

Description WebKit Commit Bot 2018-11-27 16:25:27 PST
This is an automatically generated bug from the commit-queue.
webgl/2.0.0/conformance/more/functions/bindBuffer.html has been flaky on the commit-queue.

webgl/2.0.0/conformance/more/functions/bindBuffer.html was authored by justin_fan@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/webgl/2.0.0/conformance/more/functions/bindBuffer.html

The commit-queue just saw webgl/2.0.0/conformance/more/functions/bindBuffer.html flake (DumpRenderTree crashed) while processing attachment 355792 [details] on bug 192034.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 16:25:28 PST
Created attachment 355808 [details]
Archive of layout-test-results from webkit-cq-03
Comment 2 Ryan Haddad 2018-11-28 09:58:01 PST
Thread 43 Crashed:: DFG Worklist Worker Thread
0   com.apple.JavaScriptCore      	0x000000010f4cbc55 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x000000010f49f956 JSC::CodeBlock::valueProfilePredictionForBytecodeOffset(JSC::ConcurrentJSLocker const&, int) + 38 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x000000010f5a525a JSC::DFG::ByteCodeParser::getPredictionWithoutOSRExit(unsigned int) + 90 (DFGByteCodeParser.cpp:837)
3   com.apple.JavaScriptCore      	0x000000010f59594e void JSC::DFG::ByteCodeParser::parseGetById<JSC::OpGetById>(JSC::Instruction const*) + 126 (DFGByteCodeParser.cpp:889)
4   com.apple.JavaScriptCore      	0x000000010f584d14 JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 5588 (Instruction.h:45)
5   com.apple.JavaScriptCore      	0x000000010f59942a JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
6   com.apple.JavaScriptCore      	0x000000010f5997c3 JSC::DFG::ByteCodeParser::parse() + 83 (DFGByteCodeParser.cpp:6852)
7   com.apple.JavaScriptCore      	0x000000010f59a928 JSC::DFG::parse(JSC::DFG::Graph&) + 392 (DFGByteCodeParser.cpp:93)
8   com.apple.JavaScriptCore      	0x000000010f6fede2 JSC::DFG::Plan::compileInThreadImpl() + 338 (DFGPlan.cpp:251)
9   com.apple.JavaScriptCore      	0x000000010f6fe58b JSC::DFG::Plan::compileInThread(JSC::DFG::ThreadData*) + 619 (DFGPlan.cpp:188)
10  com.apple.JavaScriptCore      	0x000000010f74bf95 JSC::DFG::Worklist::ThreadBody::work() + 277 (DumbPtrTraits.h:41)
11  com.apple.JavaScriptCore      	0x000000010f09b73e WTF::Function<void ()>::CallableWrapper<WTF::AutomaticThread::start(WTF::AbstractLocker const&)::$_0>::call() + 334 (AutomaticThread.cpp:224)
12  com.apple.JavaScriptCore      	0x000000010f0dcd84 WTF::Thread::entryPoint(WTF::Thread::NewThreadContext*) + 212 (memory:2735)
13  com.apple.JavaScriptCore      	0x000000010f0de929 WTF::wtfThreadEntryPoint(void*) + 9 (ThreadingPthreads.cpp:203)
14  libsystem_pthread.dylib       	0x00007fffdbe4793b _pthread_body + 180
15  libsystem_pthread.dylib       	0x00007fffdbe47887 _pthread_start + 286
16  libsystem_pthread.dylib       	0x00007fffdbe4708d thread_start + 13
Comment 3 Alexey Proskuryakov 2018-12-01 16:06:24 PST

*** This bug has been marked as a duplicate of bug 192050 ***