Bug 190096

Summary: REGRESSION (r236091): CSSKeywordCompletions.js has "checkout" instead of "check-out" as a value for -apple-pay-button-type
Product: WebKit Reporter: Andy Estes <aestes>
Component: New BugsAssignee: Andy Estes <aestes>
Status: RESOLVED FIXED    
Severity: Normal CC: aestes, commit-queue, drousso, joepeck, rniwa, simon.fraser, thorton, webkit-bug-importer, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Andy Estes 2018-09-28 15:27:05 PDT
REGRESSION (r236091): CSSKeywordCompletions.js has "checkout" instead of "check-out" as a value for -apple-pay-button-type
Comment 1 Andy Estes 2018-09-28 15:30:32 PDT
Created attachment 351122 [details]
Patch
Comment 2 Devin Rousso 2018-09-28 16:03:19 PDT
In reality, these completions only serve to provide autocompletion for older backends.  It's still good to have it correct, but future releases won't need this list. :)
Comment 3 WebKit Commit Bot 2018-09-28 16:13:45 PDT
Comment on attachment 351122 [details]
Patch

Clearing flags on attachment: 351122

Committed r236622: <https://trac.webkit.org/changeset/236622>
Comment 4 WebKit Commit Bot 2018-09-28 16:13:47 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2018-09-28 16:14:24 PDT
<rdar://problem/44878214>
Comment 6 Alexey Proskuryakov 2018-09-28 16:26:47 PDT
Comment on attachment 351122 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=351122&action=review

> Source/WebInspectorUI/ChangeLog:8
> +        I changed "checkout" to "check-out" in r235754, but it somehow got flipped back to "checkout" in r236091.

Is this testable?
Comment 7 Andy Estes 2018-10-04 09:36:12 PDT
(In reply to Alexey Proskuryakov from comment #6)
> Comment on attachment 351122 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=351122&action=review
> 
> > Source/WebInspectorUI/ChangeLog:8
> > +        I changed "checkout" to "check-out" in r235754, but it somehow got flipped back to "checkout" in r236091.
> 
> Is this testable?

I'm guessing no, because it would require running the front-end against an older backend. Devin would know for sure.
Comment 8 Devin Rousso 2018-10-04 09:40:52 PDT
Comment on attachment 351122 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=351122&action=review

>>> Source/WebInspectorUI/ChangeLog:8
>>> +        I changed "checkout" to "check-out" in r235754, but it somehow got flipped back to "checkout" in r236091.
>> 
>> Is this testable?
> 
> I'm guessing no, because it would require running the front-end against an older backend. Devin would know for sure.

That is correct.  We'd need to run the current WebInspector front-end against a pre-r236091 backend.