Bug 188546

Summary: [GTK] MiniBrowser: web view doesn't get the focus when new window is created
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, bugs-noreply, mcatanzaro
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch mcatanzaro: review+

Description Carlos Garcia Campos 2018-08-14 01:52:46 PDT
"User prompts that are spawned from beforeunload event handlers, are dismissed implicitly upon navigation or close window, regardless of the defined user prompt handler."

I think this is causing timeouts in tests:

  imported/w3c/webdriver/tests/forward/forward.py::test_dismissed_beforeunload
  imported/w3c/webdriver/tests/close_window/close.py::test_close_browsing_context_with_dismissed_beforeunload_prompt
  imported/w3c/webdriver/tests/back/back.py::test_dismissed_beforeunload
Comment 1 Carlos Garcia Campos 2018-08-14 06:06:41 PDT
This turned out to be a bug in MiniBrowser, it has nothing to do with WebDriver, nor with beforeunload. The problem is that the affected tests use a popup window, with an entry that is filled with send keys command. The send keys command is failing because in the new window the focus is not in the web view, it's in the toolbar, so key events are sent to the toolbar instead.
Comment 2 Carlos Garcia Campos 2018-08-14 06:12:13 PDT
Created attachment 347069 [details]
Patch
Comment 3 Carlos Garcia Campos 2018-08-16 01:16:08 PDT
Committed r234915: <https://trac.webkit.org/changeset/234915>