Bug 186267

Summary: Sync web-platform-tests repo to 197cdad
Product: WebKit Reporter: Brendan McLoughlin <brendan>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: alecflett, beidson, cdumez, commit-queue, ews, jiewen_tan, jsbell, realdawei, rniwa, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Archive of layout-test-results from ews100 for mac-sierra
none
Archive of layout-test-results from ews107 for mac-sierra-wk2
none
Archive of layout-test-results from ews124 for ios-simulator-wk2
none
Archive of layout-test-results from ews117 for mac-sierra
none
Patch
none
Archive of layout-test-results from ews101 for mac-sierra
none
Archive of layout-test-results from ews104 for mac-sierra-wk2
none
Archive of layout-test-results from ews117 for mac-sierra
none
Archive of layout-test-results from ews125 for ios-simulator-wk2
none
Patch
none
Archive of layout-test-results from ews103 for mac-sierra
none
Archive of layout-test-results from ews104 for mac-sierra-wk2
none
Archive of layout-test-results from ews116 for mac-sierra
none
Archive of layout-test-results from ews123 for ios-simulator-wk2
none
Patch
none
Archive of layout-test-results from ews104 for mac-sierra-wk2
none
Patch none

Description Brendan McLoughlin 2018-06-04 04:55:35 PDT
Sync web-platform-tests repo to 197cdad
Comment 1 Brendan McLoughlin 2018-06-06 05:22:00 PDT
Created attachment 342044 [details]
Patch
Comment 2 Brendan McLoughlin 2018-06-06 05:30:53 PDT
Since the full sync was giving webkit-patch upload some trouble this patch only syncs the following directories:

2dcontext, BackgroundSync, dom, FileAPI, IndexedDB, WebCryptoAPI, WebIDL, accname, acid, async-local-storage, background-fetch, beacon, budget-api, client-hints, common, cookie-store, cors, credential-management, css, custom-elements, device-memory, wake-lock, webaudio, webrtc, webxr, workers.

I'll submit a follow up patch for the remaining directories and a separate patch for syncing the tools directory since some of the imports uses by webkitpy/layout_tests have been changed in a recent web-platform-test commit.
Comment 3 Brendan McLoughlin 2018-06-06 09:25:58 PDT
Created attachment 342050 [details]
Patch
Comment 4 Brendan McLoughlin 2018-06-06 09:29:11 PDT
Due to merge conflict issues with the previous patch I've further limited this patch to just syncing the following directories:

2dcontext, BackgroundSync, dom, FileAPI, IndexedDB, WebCryptoAPI, WebIDL, accname, acid, async-local-storage, background-fetch, beacon, budget-api
Comment 5 Build Bot 2018-06-06 10:18:30 PDT
Comment on attachment 342050 [details]
Patch

Attachment 342050 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/8032380

New failing tests:
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/FileAPI/historical.https.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 6 Build Bot 2018-06-06 10:18:32 PDT
Created attachment 342057 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 7 Build Bot 2018-06-06 10:47:25 PDT
Comment on attachment 342050 [details]
Patch

Attachment 342050 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/8032697

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 8 Build Bot 2018-06-06 10:47:27 PDT
Created attachment 342061 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 9 Build Bot 2018-06-06 11:16:49 PDT
Comment on attachment 342050 [details]
Patch

Attachment 342050 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/8032828

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
imported/w3c/web-platform-tests/IndexedDB/wasm-module-value.html
Comment 10 Build Bot 2018-06-06 11:16:50 PDT
Comment on attachment 342050 [details]
Patch

Attachment 342050 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/8032858

New failing tests:
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-small.html
imported/w3c/web-platform-tests/budget-api/interfaces.any.html
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-large.html
imported/w3c/web-platform-tests/budget-api/interfaces.any.worker.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
imported/w3c/web-platform-tests/FileAPI/historical.https.html
Comment 11 Build Bot 2018-06-06 11:16:51 PDT
Created attachment 342064 [details]
Archive of layout-test-results from ews124 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews124  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.4
Comment 12 Build Bot 2018-06-06 11:16:52 PDT
Created attachment 342065 [details]
Archive of layout-test-results from ews117 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews117  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 13 Brendan McLoughlin 2018-06-06 11:31:44 PDT
Created attachment 342066 [details]
Patch
Comment 14 Build Bot 2018-06-06 12:45:38 PDT
Comment on attachment 342066 [details]
Patch

Attachment 342066 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/8035161

New failing tests:
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-large.html
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-small.html
imported/w3c/web-platform-tests/budget-api/interfaces.any.worker.html
Comment 15 Build Bot 2018-06-06 12:45:39 PDT
Created attachment 342073 [details]
Archive of layout-test-results from ews101 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 16 Build Bot 2018-06-06 12:52:17 PDT
Comment on attachment 342066 [details]
Patch

Attachment 342066 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/8035211

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
Comment 17 Build Bot 2018-06-06 12:52:18 PDT
Created attachment 342074 [details]
Archive of layout-test-results from ews104 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 18 Build Bot 2018-06-06 12:58:47 PDT
Comment on attachment 342066 [details]
Patch

Attachment 342066 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/8034923

New failing tests:
imported/w3c/web-platform-tests/budget-api/interfaces.any.html
Comment 19 Build Bot 2018-06-06 12:58:49 PDT
Created attachment 342076 [details]
Archive of layout-test-results from ews117 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews117  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 20 Build Bot 2018-06-06 13:23:48 PDT
Comment on attachment 342066 [details]
Patch

Attachment 342066 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/8035452

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 21 Build Bot 2018-06-06 13:23:49 PDT
Created attachment 342078 [details]
Archive of layout-test-results from ews125 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews125  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.4
Comment 22 Brendan McLoughlin 2018-06-08 06:01:10 PDT
Created attachment 342251 [details]
Patch
Comment 23 Build Bot 2018-06-08 07:12:42 PDT
Comment on attachment 342251 [details]
Patch

Attachment 342251 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/8080446

New failing tests:
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/FileAPI/historical.https.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 24 Build Bot 2018-06-08 07:12:44 PDT
Created attachment 342256 [details]
Archive of layout-test-results from ews103 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 25 Build Bot 2018-06-08 07:19:45 PDT
Comment on attachment 342251 [details]
Patch

Attachment 342251 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/8080477

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 26 Build Bot 2018-06-08 07:19:47 PDT
Created attachment 342257 [details]
Archive of layout-test-results from ews104 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 27 Build Bot 2018-06-08 07:46:42 PDT
Comment on attachment 342251 [details]
Patch

Attachment 342251 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/8080579

New failing tests:
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html
imported/w3c/web-platform-tests/FileAPI/historical.https.html
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-large.html
imported/w3c/web-platform-tests/IndexedDB/interleaved-cursors-small.html
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html
Comment 28 Build Bot 2018-06-08 07:46:43 PDT
Created attachment 342260 [details]
Archive of layout-test-results from ews116 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews116  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 29 Build Bot 2018-06-08 07:51:37 PDT
Comment on attachment 342251 [details]
Patch

Attachment 342251 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/8080569

New failing tests:
imported/w3c/web-platform-tests/IndexedDB/wasm-module-value.html
Comment 30 Build Bot 2018-06-08 07:51:38 PDT
Created attachment 342261 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.4
Comment 31 Brendan McLoughlin 2018-06-08 09:07:18 PDT
Created attachment 342275 [details]
Patch
Comment 32 Build Bot 2018-06-08 10:40:37 PDT
Comment on attachment 342275 [details]
Patch

Attachment 342275 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/8083206

New failing tests:
imported/w3c/web-platform-tests/beacon/headers/header-content-type.html
Comment 33 Build Bot 2018-06-08 10:40:38 PDT
Created attachment 342291 [details]
Archive of layout-test-results from ews104 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 34 Brendan McLoughlin 2018-06-08 11:07:23 PDT
Created attachment 342294 [details]
Patch
Comment 35 WebKit Commit Bot 2018-06-08 14:26:28 PDT
Comment on attachment 342294 [details]
Patch

Clearing flags on attachment: 342294

Committed r232641: <https://trac.webkit.org/changeset/232641>
Comment 36 WebKit Commit Bot 2018-06-08 14:26:30 PDT
All reviewed patches have been landed.  Closing bug.
Comment 37 Radar WebKit Bug Importer 2018-06-08 14:28:39 PDT
<rdar://problem/40950863>
Comment 38 Dawei Fenton (:realdawei) 2018-06-11 14:46:29 PDT
We've got 2 failing tests that are keeping the bots red:

Failing Tests:
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html

imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html


Sample output:

Regressions: Unexpected text-only failures (2)
  imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.html [ Failure ]
  imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.https.any.worker.html [ Failure ]

https://build.webkit.org/builders/Apple%20High%20Sierra%20Release%20WK2%20%28Tests%29/builds/4965/steps/layout-test/logs/stdio
Comment 39 youenn fablet 2018-06-11 14:49:09 PDT
 > Sample output:
> 
> Regressions: Unexpected text-only failures (2)
>  
> imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.
> https.any.html [ Failure ]
>  
> imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.
> https.any.worker.html [ Failure ]
> 
> https://build.webkit.org/builders/
> Apple%20High%20Sierra%20Release%20WK2%20%28Tests%29/builds/4965/steps/layout-
> test/logs/stdio

David, do you know if they just need special expectations for High Sierra or is it another issue?
Comment 40 Dawei Fenton (:realdawei) 2018-06-11 14:56:04 PDT
(In reply to youenn fablet from comment #39)
>  > Sample output:
> > 
> > Regressions: Unexpected text-only failures (2)
> >  
> > imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.
> > https.any.html [ Failure ]
> >  
> > imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_RSA-PSS.
> > https.any.worker.html [ Failure ]
> > 
> > https://build.webkit.org/builders/
> > Apple%20High%20Sierra%20Release%20WK2%20%28Tests%29/builds/4965/steps/layout-
> > test/logs/stdio
> 
> David, do you know if they just need special expectations for High Sierra or
> is it another issue?

Checking on that... it looks like these tests were renamed on 6/8 and have been failing every since.
Comment 41 Brendan McLoughlin 2018-06-12 11:45:51 PDT
David Fenton did you already address these failures or do they still need someone to update the expectations for them?
Comment 42 Dawei Fenton (:realdawei) 2018-06-12 11:46:53 PDT
(In reply to Brendan McLoughlin from comment #41)
> David Fenton did you already address these failures or do they still need
> someone to update the expectations for them?

Hi Brandon, I'm addressing them right now, should be done shortly
Comment 43 Dawei Fenton (:realdawei) 2018-06-12 11:47:49 PDT
(In reply to David Fenton from comment #42)
> (In reply to Brendan McLoughlin from comment #41)
> > David Fenton did you already address these failures or do they still need
> > someone to update the expectations for them?
> 
> Hi Brandon, I'm addressing them right now, should be done shortly

Oops I meant Brendon :)
Comment 44 Brendan McLoughlin 2018-06-12 11:49:15 PDT
Thanks
Comment 45 Chris Dumez 2018-06-12 11:50:38 PDT
(In reply to David Fenton from comment #43)
> (In reply to David Fenton from comment #42)
> > (In reply to Brendan McLoughlin from comment #41)
> > > David Fenton did you already address these failures or do they still need
> > > someone to update the expectations for them?
> > 
> > Hi Brandon, I'm addressing them right now, should be done shortly
> 
> Oops I meant Brendon :)

Lol, still not quite right :)
Comment 46 Dawei Fenton (:realdawei) 2018-06-12 11:51:58 PDT
(In reply to Chris Dumez from comment #45)
> (In reply to David Fenton from comment #43)
> > (In reply to David Fenton from comment #42)
> > > (In reply to Brendan McLoughlin from comment #41)
> > > > David Fenton did you already address these failures or do they still need
> > > > someone to update the expectations for them?
> > > 
> > > Hi Brandon, I'm addressing them right now, should be done shortly
> > 
> > Oops I meant Brendon :)
> 
> Lol, still not quite right :)

I know I caught that righ after I hit send :-) 

myBad++ Brendan!