Bug 184080

Summary: REGRESSION(r230000): [GTK] Several animation tests fail
Product: WebKit Reporter: Alicia Boya García <aboya>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, cgarcia, csaavedra, magomez
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Alicia Boya García 2018-03-28 06:07:58 PDT
The following tests fail on GTK after r230000:

    [Web Animations] Stop using internals.pauseAnimationAtTimeOnElement() in favor of Web Animations API for animations tests
    https://bugs.webkit.org/show_bug.cgi?id=184038

animations/animation-direction-normal.html
animations/animation-direction-reverse.html
animations/change-keyframes.html
animations/play-state-in-shorthand.html
animations/transform-non-accelerated.html

Maybe it's a Web Animations bug in GTK?
Comment 1 Alicia Boya García 2018-03-28 08:54:04 PDT
animations/animation-iteration-event-destroy-renderer.html started timing out at the same time, likely related.
Comment 2 Carlos Garcia Campos 2018-07-05 01:47:29 PDT
animations/change-keyframes.html is now passing since r233512
Comment 3 Claudio Saavedra 2018-09-17 05:06:28 PDT
(In reply to Alicia Boya García from comment #1)
> animations/animation-iteration-event-destroy-renderer.html started timing
> out at the same time, likely related.


This is passing now.
Comment 4 Miguel Gomez 2018-10-18 05:57:59 PDT
All of the failing tests are passing since r236541