Bug 182428

Summary: re-add ARM JSCOnly bots on buildbot waterfall
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Carlos Alberto Lopez Perez <clopez>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, bugs-noreply, cgarcia, jfbastien, joepeck, lforschler, ossy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Carlos Alberto Lopez Perez 2018-02-02 04:20:58 PST
In bug 182398 the current Linux ARM64/ARMv7 JSCOnly bots from the waterfall were removed.

We (Igalia) want to re-add them, we will be providing hardware for that.
Comment 1 Carlos Alberto Lopez Perez 2018-02-02 04:31:02 PST
Created attachment 332957 [details]
Patch
Comment 2 Csaba Osztrogon√°c 2018-02-02 04:32:35 PST
Comment on attachment 332957 [details]
Patch

LGTM, thanks for taking over the bots. ;)
Comment 3 Carlos Alberto Lopez Perez 2018-02-02 04:36:21 PST
Comment on attachment 332957 [details]
Patch

Clearing flags on attachment: 332957

Committed r228004: <https://trac.webkit.org/changeset/228004>
Comment 4 Carlos Alberto Lopez Perez 2018-02-02 04:36:26 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2018-02-02 04:39:47 PST
<rdar://problem/37152756>
Comment 6 Carlos Alberto Lopez Perez 2018-02-02 04:40:27 PST
Thanks, I will ask for a master restart to the webkit admins to make the changes effective, then will start providing machines to run this bots (I have the ARM64 already working; and the ARMv7 ones should be ready for next week).
I will look also into try to seek faster hardware for the test step as currently its running on a RPi and is really slow.