Bug 181865

Summary: Web Inspector: Canvas Tab: Multiple "waiting for frames" messages displayed
Product: WebKit Reporter: Matt Baker <mattbaker>
Component: Web InspectorAssignee: Matt Baker <mattbaker>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, drousso, inspector-bugzilla-changes, webkit-bug-importer
Priority: P1 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 173807, 175485    
Attachments:
Description Flags
[Image] Multiple "Waiting for frames…" messages
none
Patch none

Description Matt Baker 2018-01-19 11:13:47 PST
Created attachment 331757 [details]
[Image] Multiple "Waiting for frames…" messages

Summary:
Multiple "waiting for frames" messages displayed. Only the recording canvas should update its status.

See attached screenshot.
Comment 1 Radar WebKit Bug Importer 2018-01-19 11:16:25 PST
<rdar://problem/36664737>
Comment 2 Matt Baker 2018-01-19 11:24:28 PST
Created attachment 331760 [details]
Patch
Comment 3 Devin Rousso 2018-01-19 11:45:39 PST
*** Bug 180599 has been marked as a duplicate of this bug. ***
Comment 4 Devin Rousso 2018-01-19 11:47:23 PST
Comment on attachment 331760 [details]
Patch

r=me
Comment 5 Matt Baker 2018-01-19 13:22:57 PST
EWS failures look spurious, but I'll give it a little longer.
Comment 6 WebKit Commit Bot 2018-01-19 15:01:15 PST
Comment on attachment 331760 [details]
Patch

Clearing flags on attachment: 331760

Committed r227243: <https://trac.webkit.org/changeset/227243>
Comment 7 WebKit Commit Bot 2018-01-19 15:01:17 PST
All reviewed patches have been landed.  Closing bug.