Bug 179132

Summary: Web Inspector: Move InspectorAgents into a folder
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: buildbot, hi, inspector-bugzilla-changes, joepeck, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[PATCH] Proposed Fix hi: review+

Description Joseph Pecoraro 2017-11-01 12:00:33 PDT
Move InspectorAgents into a folder

Lets group all the agents together. I'm looking at:

> ...
> ├── InspectorAllInOne.cpp
> ├── InspectorClient.cpp
> ├── InspectorClient.h
> ├── InspectorController.cpp
> ├── InspectorController.h
> ├── InspectorInstrumentation.cpp
> ├── InspectorInstrumentation.h
> ├── InspectorWebAgentBase.h
> ├── InstrumentingAgents.cpp
> ├── InstrumentingAgents.h
> ├── PageScriptDebugServer.cpp
> ├── PageScriptDebugServer.h
> ├── WorkerInspectorController.cpp
> ├── WorkerInspectorController.h
> ├── WorkerScriptDebugServer.cpp
> ├── WorkerScriptDebugServer.h
> └── agents
>     ├── InspectorApplicationCacheAgent.cpp
>     ├── InspectorApplicationCacheAgent.h
>     ├── InspectorCSSAgent.cpp
>     ├── InspectorCSSAgent.h
>     ├── InspectorCanvasAgent.cpp
>     ├── InspectorCanvasAgent.h
>     ├── InspectorDOMAgent.cpp
>     ├── InspectorDOMAgent.h
>     ...
>     ├── WebConsoleAgent.cpp
>     ├── WebConsoleAgent.h
>     ├── WebDebuggerAgent.cpp
>     ├── WebDebuggerAgent.h
>     ├── WebHeapAgent.cpp
>     ├── WebHeapAgent.h
>     ├── page
>     │   ├── PageConsoleAgent.cpp
>     │   ├── PageConsoleAgent.h
>     │   ├── PageDebuggerAgent.cpp
>     │   ├── PageDebuggerAgent.h
>     │   ├── PageHeapAgent.cpp
>     │   ├── PageHeapAgent.h
>     │   ├── PageRuntimeAgent.cpp
>     │   └── PageRuntimeAgent.h
>     └── worker
>         ├── WorkerConsoleAgent.cpp
>         ├── WorkerConsoleAgent.h
>         ├── WorkerDebuggerAgent.cpp
>         ├── WorkerDebuggerAgent.h
>         ├── WorkerRuntimeAgent.cpp
>         └── WorkerRuntimeAgent.h
Comment 1 Joseph Pecoraro 2017-11-01 12:02:35 PDT
Created attachment 325608 [details]
[PATCH] Proposed Fix
Comment 2 Build Bot 2017-11-01 12:08:19 PDT
Attachment 325608 [details] did not pass style-queue:


ERROR: Source/WebCore/inspector/agents/InspectorPageAgent.cpp:205:  Should have a space between // and comment  [whitespace/comments] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:451:  'document' is incorrectly named. It should be named 'protector' or 'protectedDocument'.  [readability/naming/protected] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:583:  One space before end of line comments  [whitespace/comments] [5]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:601:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:612:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:1015:  'node' is incorrectly named. It should be named 'protector' or 'protectedInspectedNode'.  [readability/naming/protected] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:1553:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:2017:  Should have a space between // and comment  [whitespace/comments] [4]
ERROR: Source/WebCore/inspector/agents/InspectorDOMAgent.cpp:2018:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/WebCore/inspector/agents/InspectorTimelineAgent.cpp:702:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
ERROR: Source/WebCore/inspector/agents/page/PageDebuggerAgent.h:88:  The parameter name "const" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 11 in 52 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Devin Rousso 2017-11-01 13:08:02 PDT
Comment on attachment 325608 [details]
[PATCH] Proposed Fix

r=me.  Awesome!  Please wait till the windows bot is green :)
Comment 4 Joseph Pecoraro 2017-11-02 11:26:19 PDT
<https://trac.webkit.org/changeset/224345/webkit>
Comment 5 Radar WebKit Bug Importer 2017-11-15 12:26:32 PST
<rdar://problem/35567540>