Bug 178938

Summary: REGRESSION (r223999): Multiple flaky xsl LayoutTests
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: jlewis3, rniwa
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=178715

Description Ryan Haddad 2017-10-27 09:00:35 PDT
LayoutTest fast/xsl/xslt-enc.xml is a flaky failure

https://build.webkit.org/results/Apple%20El%20Capitan%20Release%20WK2%20(Tests)/r224110%20(5559)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fxsl%2Fxslt-enc.xml

--- /Volumes/Data/slave/elcapitan-release-tests-wk2/build/layout-test-results/fast/xsl/xslt-enc-expected.txt
+++ /Volumes/Data/slave/elcapitan-release-tests-wk2/build/layout-test-results/fast/xsl/xslt-enc-actual.txt
@@ -1,11 +1,2 @@
 layer at (0,0) size 800x600
   RenderView at (0,0) size 800x600
-layer at (0,0) size 800x600
-  RenderBlock {HTML} at (0,0) size 800x600
-    RenderBody {BODY} at (8,8) size 784x584
-      RenderText {#text} at (0,0) size 259x18
-        text run at (0,0) width 259: "CHARACTERS IN XSLT: \x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9} "
-      RenderBR {BR} at (258,14) size 1x0
-      RenderBR {BR} at (0,18) size 0x18
-      RenderText {#text} at (0,36) size 318x18
-        text run at (0,36) width 318: "SOURCE XML: \x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}\x{E9}"
Comment 1 Ryan Haddad 2017-10-27 09:01:01 PDT
This is limited to Release WK2 bots.
Comment 2 Ryan Haddad 2017-10-27 09:51:07 PDT
This must be related to https://trac.webkit.org/changeset/223999
Comment 3 Ryan Haddad 2017-10-27 09:55:04 PDT
Similar failure/diff with fast/xsl/xslt-relative-path.xml here:

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK2%20(Tests)/r224084%20(5308)/results.html
Comment 4 Ryan Haddad 2017-10-27 09:57:22 PDT
Not same diff, but another flaky test after this change http/tests/security/contentSecurityPolicy/xsl-unaffected-by-style-src-2.php

https://build.webkit.org/results/Apple%20High%20Sierra%20Release%20WK2%20(Tests)/r224002%20(715)/results.html
Comment 5 Ryan Haddad 2017-10-27 10:06:48 PDT
Rolled out the change.

*** This bug has been marked as a duplicate of bug 178715 ***