Bug 178825

Summary: REGRESSION(r223937): Use of -fobjc-weak causes build failures with older compilers
Product: WebKit Reporter: Michael Saboff <msaboff>
Component: JavaScriptCoreAssignee: Michael Saboff <msaboff>
Status: RESOLVED FIXED    
Severity: Normal CC: buildbot, commit-queue, keith_miller, mark.lam, sbarati, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Michael Saboff 2017-10-25 13:25:47 PDT
Turns out we can eliminate this setting and just turn on ARC for ARM64_32.
Comment 1 Radar WebKit Bug Importer 2017-10-25 13:28:56 PDT
<rdar://problem/35181521>
Comment 2 Michael Saboff 2017-10-25 13:34:16 PDT
Created attachment 324882 [details]
Patch
Comment 3 Mark Lam 2017-10-25 13:35:53 PDT
Comment on attachment 324882 [details]
Patch

r=me
Comment 4 WebKit Commit Bot 2017-10-25 14:12:42 PDT
Comment on attachment 324882 [details]
Patch

Clearing flags on attachment: 324882

Committed r223980: <https://trac.webkit.org/changeset/223980>
Comment 5 WebKit Commit Bot 2017-10-25 14:12:43 PDT
All reviewed patches have been landed.  Closing bug.