Bug 178500

Summary: Web Inspector: Click to add properties in spreadsheet mode broken
Product: WebKit Reporter: Chris Chiera <chris>
Component: Web InspectorAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: inspector-bugzilla-changes, nvasilyev
Priority: P2    
Version: Safari Technology Preview   
Hardware: All   
OS: All   

Description Chris Chiera 2017-10-18 19:15:07 PDT
In Chrome and Safari/Webkit (without spreadsheet setting enabled) you simply click anywhere beneath a rule or in the empty space to the right and add creates a new line where you can enter a new rule.

In the latest Webkit, with spreadsheet setting enabled to mimic Chrome's functionality, adding a rule by clicking in the empty space no longer works. The only way currently in that scenario to add a property is to click on an existing rule and click tab or return.
Comment 1 Nikita Vasilyev 2017-10-18 19:21:57 PDT
It is in the roadmap.

*** This bug has been marked as a duplicate of bug 178022 ***