Bug 178476

Summary: REGRESSION(r223321): This protocol change broke some internal builds (Requested by brrian__ on #webkit).
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, buildbot, cdumez, dbates, drousso, esprehn+autocc, joepeck, kangil.han, keith_miller, mark.lam, msaboff, sbarati, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 177451    
Attachments:
Description Flags
ROLLOUT of r223321 none

Description WebKit Commit Bot 2017-10-18 11:19:07 PDT
https://trac.webkit.org/changeset/223321 broke the build:
This protocol change broke some internal builds (Requested by brrian__ on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2017-10-18 11:19:18 PDT
Created attachment 324138 [details]
ROLLOUT of r223321

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2017-10-18 11:28:25 PDT
Comment on attachment 324138 [details]
ROLLOUT of r223321

Clearing flags on attachment: 324138

Committed r223618: <https://trac.webkit.org/changeset/223618>
Comment 3 WebKit Commit Bot 2017-10-18 11:28:27 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2017-10-18 11:28:52 PDT
<rdar://problem/35056300>
Comment 5 Devin Rousso 2017-10-18 11:33:57 PDT
@brrian can you provide me with any info as to what broke the build?  I've used this feature already when debugging WebInspector and it has been extremely useful.
Comment 6 BJ Burg 2017-10-18 11:40:05 PDT
(In reply to Devin Rousso from comment #5)
> @brrian can you provide me with any info as to what broke the build?  I've
> used this feature already when debugging WebInspector and it has been
> extremely useful.

You really, really don't want to know. :(