Bug 176806

Summary: [SOUP] Layout test media/track/track-text-track-cue-list.html crash with g_source_set_ready_time: assertion 'source->ref_count > 0' failed
Product: WebKit Reporter: Michael Catanzaro <mcatanzaro>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, cgarcia, clopez
Priority: P2    
Version: Other   
Hardware: PC   
OS: Linux   
See Also: https://bugs.webkit.org/show_bug.cgi?id=171555
https://bugzilla.gnome.org/show_bug.cgi?id=781601
https://bugzilla.gnome.org/show_bug.cgi?id=790894
Attachments:
Description Flags
Patch clopez: review+

Description Michael Catanzaro 2017-09-12 13:34:23 PDT
Since enabling fatal criticals for layout tests, test media/track/track-text-track-cue-list.html now crashes with the following error:

STDERR: g_source_set_ready_time: assertion 'source->ref_count > 0' failed

Updating expectations accordingly.

The backtrace is, unfortunately, quite a doozy:

Thread 1 (Thread 0x7f1102c42a80 (LWP 32732)):
#0  _g_log_abort () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmessages.c:549
#1  0x00007f110e43d1b5 in g_logv () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmessages.c:1357
#2  0x00007f110e43d302 in g_log () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmessages.c:1398
#3  0x00007f110e510655 in g_closure_invoke () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gclosure.c:804
#4  0x00007f110e521ea2 in signal_emit_unlocked_R () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gsignal.c:3635
#5  0x00007f110e52aa41 in g_signal_emit_valist () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gsignal.c:3391
#6  0x00007f110e52ae52 in g_signal_emit () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gsignal.c:3447
#7  0x00007f110e592c68 in g_cancellable_cancel () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gcancellable.c:508
#8  0x00007f110e61ed03 in _g_dbus_worker_close () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gdbusprivate.c:1689
#9  0x00007f110e61ed55 in _g_dbus_worker_stop () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gdbusprivate.c:1710
#10 0x00007f110e60ae8f in g_dbus_connection_dispose () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gdbusconnection.c:630
#11 0x00007f110e514fb5 in g_object_unref () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:3148
#12 0x00007f110e61b688 in g_dbus_proxy_finalize () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gdbusproxy.c:228
#13 0x00007f110e51502a in g_object_unref () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:3185
#14 0x00007f110e64b88a in g_proxy_resolver_portal_finalize () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/gproxyresolverportal.c:168
#15 0x00007f110e51502a in g_object_unref () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:3185
#16 0x00007f110e5b944a in try_implementation () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/giomodule.c:787
#17 0x00007f110e5b9580 in _g_io_module_get_default () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gio/giomodule.c:882
#18 0x00007f110e36d7a5 in soup_proxy_resolver_default_constructed () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/libsoup-2.57.1/libsoup/soup-proxy-resolver-default.c:84
#19 0x00007f110e515ae7 in g_object_new_internal () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:1823
#20 0x00007f110e516e9d in g_object_newv () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:1930
#21 0x00007f110e51761c in g_object_new () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:1623
#22 0x00007f110e3771ac in soup_session_add_feature_by_type () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/libsoup-2.57.1/libsoup/soup-session.c:2718
#23 0x00007f110e377c3b in soup_session_set_property () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/libsoup-2.57.1/libsoup/soup-session.c:757
#24 0x00007f110e5178f0 in object_set_property () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:1423
#25 g_object_set_valist () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:2167
#26 0x00007f110e51805f in g_object_set () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/gobject/gobject.c:2277
#27 0x00007f1113f02f7a in _ZN7WebCore18SoupNetworkSessionC2EP14_SoupCookieJar () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#28 0x00007f1113ef249d in _ZN7WebCore21NetworkStorageSession25switchToNewTestingSessionEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#29 0x00007f111310872e in _ZN6WebKit10WebProcess20initializeWebProcessEONS_28WebProcessCreationParametersE () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#30 0x00007f11133ab82a in _ZN3IPC13handleMessageIN8Messages10WebProcess20InitializeWebProcessEN6WebKit10WebProcessEMS5_FvONS4_28WebProcessCreationParametersEEEEvRNS_7DecoderEPT0_T1_ () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#31 0x00007f11133aac74 in _ZN6WebKit10WebProcess27didReceiveWebProcessMessageERN3IPC10ConnectionERNS1_7DecoderE () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#32 0x00007f1112f9193b in _ZN3IPC10Connection15dispatchMessageESt10unique_ptrINS_7DecoderESt14default_deleteIS2_EE () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#33 0x00007f1112f9286c in _ZN3IPC10Connection18dispatchOneMessageEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#34 0x00007f1110e40d00 in _ZN3WTF7RunLoop11performWorkEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#35 0x00007f1110e76ab9 in _ZZN3WTF7RunLoopC4EvENUlPvE_4_FUNES1_ () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#36 0x00007f110e4365ca in g_main_dispatch () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3212
#37 g_main_context_dispatch () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3865
#38 0x00007f110e436948 in g_main_context_iterate () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3938
#39 0x00007f110e436c62 in g_main_loop_run () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:4134
#40 0x00007f1110e77460 in _ZN3WTF7RunLoop3runEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#41 0x00007f111335d8f2 in _ZN6WebKit16ChildProcessMainINS_10WebProcessENS_14WebProcessMainEEEiiPPc () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#42 0x00007f110a0122b1 in __libc_start_main (main=0x7f111598cd20 <main>, argc=2, argv=0x7ffe96c494f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe96c494e8) at ../csu/libc-start.c:291
#43 0x00007f111598cdaa in _start ()
Comment 1 Michael Catanzaro 2017-11-06 18:59:09 PST
media/track/track-id.html is crashing with the same critical. (But it's coming from the network process, so we can't get a backtrace from the bots... could be a different issue.) Updating expectations.
Comment 2 Carlos Garcia Campos 2017-11-27 02:57:43 PST
*** Bug 171555 has been marked as a duplicate of this bug. ***
Comment 3 Carlos Garcia Campos 2017-11-27 03:01:54 PST
The fix for this landed in glib 2.52.3. We are currently using 2.52.1, I think we can either upgrade to 2.52.3 to keep using 2.52 branch or upgrade directly to 2.54.2 which is the latest stable.
Comment 4 Carlos Garcia Campos 2017-11-27 03:03:12 PST
Btw, this is a race condition and can happen with any test, it's not specific to media/track/track-text-track-cue-list.html.
Comment 5 Carlos Garcia Campos 2017-11-27 04:46:42 PST
Created attachment 327628 [details]
Patch
Comment 6 Carlos Garcia Campos 2017-11-27 05:21:02 PST
Committed r225166: <https://trac.webkit.org/changeset/225166>