Bug 175683

Summary: Fix the build on other platforms after r220865
Product: WebKit Reporter: Wenson Hsieh <wenson_hsieh>
Component: WebCore Misc.Assignee: Wenson Hsieh <wenson_hsieh>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, mitz, thorton, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Wenson Hsieh 2017-08-17 13:08:09 PDT
Currently, NSItemProvider-related UIPasteboard APIs only exist in the iOS 11 SDK. I tried to guard iOS 10 codepaths in PlatformPasteboardIOS.mm with __IPHONE_OS_VERSION_MAX_ALLOWED < 110000 and assume that item provider APIs would be available otherwise, but this is not the case. Revert to special casing code that uses item provider APIs with __IPHONE_OS_VERSION_MIN_REQUIRED >= 110000, instead of the inverse.
Comment 1 Wenson Hsieh 2017-08-17 13:25:20 PDT
Created attachment 318409 [details]
Patch
Comment 2 Wenson Hsieh 2017-08-17 14:50:18 PDT
Comment on attachment 318409 [details]
Patch

Thanks Tim!
Comment 3 WebKit Commit Bot 2017-08-17 15:20:06 PDT
Comment on attachment 318409 [details]
Patch

Clearing flags on attachment: 318409

Committed r220883: <http://trac.webkit.org/changeset/220883>
Comment 4 WebKit Commit Bot 2017-08-17 15:20:08 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2017-08-17 15:21:03 PDT
<rdar://problem/33951376>