Bug 175577

Summary: REGRESSION(r??????): Layout test fast/css/tagname-and-namespace-case-sensitivity-xml-in-html.html crashing in WebCore::GLContextGLX::~GLContextGLX()
Product: WebKit Reporter: Michael Catanzaro <mcatanzaro>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, cgarcia, magomez, mcatanzaro, Ms2ger, zan
Priority: P2    
Version: Other   
Hardware: PC   
OS: Linux   

Description Michael Catanzaro 2017-08-15 09:26:44 PDT
Layout test fast/css/tagname-and-namespace-case-sensitivity-xml-in-html.html is flakily crashing in WebCore::GLContextGLX::~GLContextGLX(). First recorded crash is r220556 from five days ago, though that's surely not to blame. Can someone check which of the TextureMapper/GLContext refactorings were likely to have introduced this crash?

I'll add a crash expectation for this test, but I'm sure we'll find more affected tests sooner or later.
Comment 1 Michael Catanzaro 2017-08-15 09:27:04 PDT
Almost forgot the backtrace:

Thread 1 (Thread 0x2b5745301700 (LWP 15986)):
#0  0x00002b56e19fb705 in _ZN7WebCore12GLContextGLXD2Ev () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#1  0x00002b56e19fb789 in _ZN7WebCore12GLContextGLXD0Ev () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#2  0x00002b56e0d3f52c in _ZN3WTF8FunctionIFvvEE15CallableWrapperIZN6WebKit18ThreadedCompositor10invalidateEvEUlvE_E4callEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#3  0x00002b56e0d3dc63 in _ZN3WTF8FunctionIFvvEE15CallableWrapperIZN6WebKit18CompositingRunLoop15performTaskSyncEOS2_EUlvE_E4callEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libwebkit2gtk-4.0.so.37
#4  0x00002b56e4e49320 in _ZN3WTF7RunLoop11performWorkEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#5  0x00002b56e4e7ef99 in _ZZN3WTF7RunLoopC4EvENUlPvE_4_FUNES1_ () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#6  0x00002b56e656b5ca in g_main_dispatch () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3212
#7  g_main_context_dispatch () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3865
#8  0x00002b56e656b948 in g_main_context_iterate () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:3938
#9  0x00002b56e656bc62 in g_main_loop_run () at /home/slave/webkitgtk/gtk-linux-64-release-tests/build/WebKitBuild/DependenciesGTK/Source/glib-2.52.1/glib/gmain.c:4134
#10 0x00002b56e4e7f940 in _ZN3WTF7RunLoop3runEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#11 0x00002b56e4e7e974 in _ZN3WTF8FunctionIFvvEE15CallableWrapperIZNS_9WorkQueue18platformInitializeEPKcNS4_4TypeENS4_3QOSEEUlvE_E4callEv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#12 0x00002b56e4e4aa0b in _ZN3WTF6Thread10entryPointEPNS0_16NewThreadContextE () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#13 0x00002b56e4e7db99 in _ZN3WTFL19wtfThreadEntryPointEPv () from /home/slave/webkitgtk/gtk-linux-64-release/build/WebKitBuild/Release/lib/libjavascriptcoregtk-4.0.so.18
#14 0x00002b56e9c4b494 in start_thread (arg=0x2b5745301700) at pthread_create.c:333
#15 0x00002b56eae2793f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97
Comment 2 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-17 01:32:53 PDT
In loader/load-defer.html today: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20(Tests)/r220823%20(2663)/results.html (same backtrace).

I'm pretty sure I've seen it in a bunch of other tests as well.
Comment 3 Carlos Garcia Campos 2017-08-31 06:30:17 PDT

*** This bug has been marked as a duplicate of bug 175819 ***
Comment 4 Michael Catanzaro 2017-08-31 11:08:00 PDT
(In reply to Carlos Garcia Campos from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 175819 ***

We need to remove the crash expectation, then.
Comment 5 Michael Catanzaro 2017-08-31 11:09:05 PDT
Committed r221424: <http://trac.webkit.org/changeset/221424>