Bug 17555

Summary: REGRESSION (r27351): Thumbnails positioned wrong on Getty Images results page
Product: WebKit Reporter: mitz
Component: Layout and RenderingAssignee: mitz
Status: RESOLVED FIXED    
Severity: Major Keywords: InRadar, Regression
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
URL: http://www.gettyimages.com/Search/Search.aspx?src=quick&contractUrl=1&family=creative&phrase=failure
Attachments:
Description Flags
Reduction
none
Disallow table cells as relayout boundaries because their height can change darin: review+

Description mitz 2008-02-26 07:53:19 PST
Some of the thumbnails at the URL are positioned too low, showing behind their captions. This seems to happen to images that load (and get their final size) after the page is already laid out, so to reproduce you may need a slowish network and a clear cache.

I could not reproduce the problem in Safari 3.0.4.
Comment 1 mitz 2008-02-26 09:11:58 PST
Works: r27337  Fails: r27373
Probably <http://trac.webkit.org/projects/webkit/changeset/27351>
Comment 2 mitz 2008-02-26 09:22:38 PST
Created attachment 19381 [details]
Reduction
Comment 3 mitz 2008-02-26 10:38:43 PST
<rdar://problem/5766016>
Comment 4 mitz 2008-02-26 10:43:40 PST
Created attachment 19382 [details]
Disallow table cells as relayout boundaries because their height can change
Comment 5 Darin Adler 2008-02-26 10:47:56 PST
Comment on attachment 19382 [details]
Disallow table cells as relayout boundaries because their height can change

I think the comment from the change log should be in the code instead.

r=me
Comment 6 mitz 2008-02-26 11:02:23 PST
Fixed in <http://trac.webkit.org/projects/webkit/changeset/30595>.