Bug 170902

Summary: [GTK] Web Inspector: gtk/NavigationItemCurleyBraces.svg is licensed under NonCommercial CC
Product: WebKit Reporter: Fujii Hironori <Hironori.Fujii>
Component: Web InspectorAssignee: Fujii Hironori <Hironori.Fujii>
Status: RESOLVED FIXED    
Severity: Normal CC: agomez, aperez, bugs-noreply, commit-queue, inspector-bugzilla-changes, mcatanzaro
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
screenshot of before and after this fix none

Description Fujii Hironori 2017-04-17 07:26:34 PDT
[GTK] Web Inspector: gtk/NavigationItemCurleyBraces.svg is licensed under NonCommercial CC

This is the original file
https://github.com/tanty/design-hodgepodge/blob/master/WebKit/WebInspector/NavigationItemCurleyBraces.svg

>  <metadata
>     id="metadata8343">
>    <rdf:RDF>
>      <cc:Work
>         rdf:about="">
>        <dc:format>image/svg+xml</dc:format>
>        <dc:type
>           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
>        <dc:title></dc:title>
>        <cc:license
>           rdf:resource="http://creativecommons.org/licenses/by-nc-sa/3.0/" />
>      </cc:Work>
>      <cc:License
>         rdf:about="http://creativecommons.org/licenses/by-nc-sa/3.0/">
>        <cc:permits
>           rdf:resource="http://creativecommons.org/ns#Reproduction" />
>        <cc:permits
>           rdf:resource="http://creativecommons.org/ns#Distribution" />
>        <cc:requires
>           rdf:resource="http://creativecommons.org/ns#Notice" />
>        <cc:requires
>           rdf:resource="http://creativecommons.org/ns#Attribution" />
>        <cc:prohibits
>           rdf:resource="http://creativecommons.org/ns#CommercialUse" />
>        <cc:permits
>           rdf:resource="http://creativecommons.org/ns#DerivativeWorks" />
>        <cc:requires
>           rdf:resource="http://creativecommons.org/ns#ShareAlike" />
>      </cc:License>
>    </rdf:RDF>
>  </metadata>
Comment 1 Michael Catanzaro 2017-04-18 20:12:48 PDT
This means that WebKitGTK+ releases that included this icon are unsuitable for inclusion in Fedora and Debian, as content with a non-commercial use restriction is not permissible in these distributions. I'm sure other distributions have similar policies.

Andres, are you the original creator of this image? Was this just a mistake? If so, can you state here on Bugzilla that this choice of license is a mistake and that the intended license was CC-BY-SA?
Comment 2 Fujii Hironori 2017-04-26 21:07:13 PDT
Created attachment 308331 [details]
Patch
Comment 3 Fujii Hironori 2017-04-26 21:40:47 PDT
Created attachment 308335 [details]
screenshot of before and after this fix
Comment 4 Michael Catanzaro 2017-04-27 08:15:58 PDT
So I see that the new image looks better, but that's incidental to the title of the bug.

I also see that the license inside the image file is correct, and unchanged.

(In reply to Fujii Hironori from comment #0)
> [GTK] Web Inspector: gtk/NavigationItemCurleyBraces.svg is licensed under
> NonCommercial CC
> 
> This is the original file
> https://github.com/tanty/design-hodgepodge/blob/master/WebKit/WebInspector/
> NavigationItemCurleyBraces.svg
> 
> >  <metadata
> >     id="metadata8343">
> >    <rdf:RDF>
> >      <cc:Work
> >         rdf:about="">
> >        <dc:format>image/svg+xml</dc:format>
> >        <dc:type
> >           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
> >        <dc:title></dc:title>
> >        <cc:license
> >           rdf:resource="http://creativecommons.org/licenses/by-nc-sa/3.0/" />
> >      </cc:Work>
> >      <cc:License
> >         rdf:about="http://creativecommons.org/licenses/by-nc-sa/3.0/">
> >        <cc:permits
> >           rdf:resource="http://creativecommons.org/ns#Reproduction" />
> >        <cc:permits
> >           rdf:resource="http://creativecommons.org/ns#Distribution" />
> >        <cc:requires
> >           rdf:resource="http://creativecommons.org/ns#Notice" />
> >        <cc:requires
> >           rdf:resource="http://creativecommons.org/ns#Attribution" />
> >        <cc:prohibits
> >           rdf:resource="http://creativecommons.org/ns#CommercialUse" />
> >        <cc:permits
> >           rdf:resource="http://creativecommons.org/ns#DerivativeWorks" />
> >        <cc:requires
> >           rdf:resource="http://creativecommons.org/ns#ShareAlike" />
> >      </cc:License>
> >    </rdf:RDF>
> >  </metadata>

Where is this metadata coming from? It is obviously not inside the file.
Comment 5 Adrian Perez 2017-04-27 08:35:38 PDT
(In reply to Michael Catanzaro from comment #4)
> So I see that the new image looks better, but that's incidental to the title
> of the bug.
> 
> I also see that the license inside the image file is correct, and unchanged.
> 
> (In reply to Fujii Hironori from comment #0)
> > [GTK] Web Inspector: gtk/NavigationItemCurleyBraces.svg is licensed under
> > NonCommercial CC
> > 
> > This is the original file
> > https://github.com/tanty/design-hodgepodge/blob/master/WebKit/WebInspector/
> > NavigationItemCurleyBraces.svg
> > 
> > >  <metadata
> > >     id="metadata8343">
> > >    <rdf:RDF>
> > >      <cc:Work
> > >         rdf:about="">
> > >        <dc:format>image/svg+xml</dc:format>
> > >        <dc:type
> > >           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
> > >        <dc:title></dc:title>
> > >        <cc:license
> > >           rdf:resource="http://creativecommons.org/licenses/by-nc-sa/3.0/" />
> > >      </cc:Work>
> > >      <cc:License
> > >         rdf:about="http://creativecommons.org/licenses/by-nc-sa/3.0/">
> > >        <cc:permits
> > >           rdf:resource="http://creativecommons.org/ns#Reproduction" />
> > >        <cc:permits
> > >           rdf:resource="http://creativecommons.org/ns#Distribution" />
> > >        <cc:requires
> > >           rdf:resource="http://creativecommons.org/ns#Notice" />
> > >        <cc:requires
> > >           rdf:resource="http://creativecommons.org/ns#Attribution" />
> > >        <cc:prohibits
> > >           rdf:resource="http://creativecommons.org/ns#CommercialUse" />
> > >        <cc:permits
> > >           rdf:resource="http://creativecommons.org/ns#DerivativeWorks" />
> > >        <cc:requires
> > >           rdf:resource="http://creativecommons.org/ns#ShareAlike" />
> > >      </cc:License>
> > >    </rdf:RDF>
> > >  </metadata>
> 
> Where is this metadata coming from? It is obviously not inside the file.

They are in the original file at Andrés' repository, check out this:

  https://raw.githubusercontent.com/tanty/design-hodgepodge/master/WebKit/WebInspector/NavigationItemCurleyBraces.svg
Comment 6 Michael Catanzaro 2017-04-27 08:48:17 PDT
Comment on attachment 308331 [details]
Patch

OK whatever. The new image is better anyway, so let's use it.
Comment 7 WebKit Commit Bot 2017-04-27 08:52:15 PDT
Comment on attachment 308331 [details]
Patch

Clearing flags on attachment: 308331

Committed r215868: <http://trac.webkit.org/changeset/215868>
Comment 8 WebKit Commit Bot 2017-04-27 08:52:17 PDT
All reviewed patches have been landed.  Closing bug.