Bug 167325

Summary: Distinguish between autoplay policies for all media vs. media without sound
Product: WebKit Reporter: Matt Rajca <mrajca>
Component: MediaAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: buildbot, commit-queue, rniwa
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch
achristensen: review+, commit-queue: commit-queue-
Archive of layout-test-results from ews107 for mac-elcapitan-wk2 none

Description Matt Rajca 2017-01-23 14:43:37 PST
Let clients specify whether they want to allow autoplay for all media or just media without sound as part of website policies.
Comment 1 Matt Rajca 2017-01-23 14:48:38 PST
Created attachment 299543 [details]
Patch
Comment 2 Matt Rajca 2017-01-23 15:17:13 PST
Created attachment 299546 [details]
Patch
Comment 3 Matt Rajca 2017-01-23 16:17:42 PST
Created attachment 299552 [details]
Patch
Comment 4 Build Bot 2017-01-23 17:46:59 PST
Comment on attachment 299552 [details]
Patch

Attachment 299552 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/2937938

Number of test failures exceeded the failure limit.
Comment 5 Build Bot 2017-01-23 17:47:02 PST
Created attachment 299563 [details]
Archive of layout-test-results from ews107 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 6 WebKit Commit Bot 2017-01-23 18:21:15 PST
Comment on attachment 299552 [details]
Patch

Rejecting attachment 299552 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-02', 'land-attachment', '--force-clean', '--non-interactive', '--parent-command=commit-queue', 299552, '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Last 500 characters of output:
/git.webkit.org/WebKit
   c89e13b..27e667b  master     -> origin/master
Partial-rebuilding .git/svn/refs/remotes/origin/master/.rev_map.268f45cc-cd09-0410-ab3c-d52691b4dbfc ...
Currently at 211071 = c89e13b17f015f4d9c3c8a205ff6048a4cc75dcb
r211072 = 27e667b0798ad4487123ab323300200e0cd068a4
Done rebuilding .git/svn/refs/remotes/origin/master/.rev_map.268f45cc-cd09-0410-ab3c-d52691b4dbfc
First, rewinding head to replay your work on top of it...
Fast-forwarded master to refs/remotes/origin/master.

Full output: http://webkit-queues.webkit.org/results/2938147
Comment 7 Matt Rajca 2017-01-24 13:13:22 PST
This work has been integrated into: https://bugs.webkit.org/show_bug.cgi?id=167355

*** This bug has been marked as a duplicate of bug 167355 ***