Bug 167109

Summary: [Gstreamer] [MSE] [GTK] test imported/w3c/web-platform-tests/media-source/mediasource-seek-beyond-duration.html crashes
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, cgarcia, eocanha
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=167108
https://bugs.webkit.org/show_bug.cgi?id=165394

Description Carlos Alberto Lopez Perez 2017-01-16 19:25:26 PST
Regressions: Unexpected crashes (1)
  imported/w3c/web-platform-tests/media-source/mediasource-seek-beyond-duration.html [ Crash ]
Comment 1 Carlos Alberto Lopez Perez 2017-01-16 19:28:33 PST
The test timeouts sometimes also
Comment 2 Carlos Alberto Lopez Perez 2017-01-16 19:44:33 PST
Updated TestExpectations file in r210794: <http://trac.webkit.org/changeset/210794>
Comment 3 Enrique OcaƱa 2017-01-17 01:14:36 PST
The reason why all these imported/w3c/web-platform-tests/media-source tests should be skipped is explained in https://bugs.webkit.org/attachment.cgi?id=297003&action=diff (line 234): "Webm is required by the tests but we don't support it."

Please, skip these tests again until webm support is enabled.
Comment 4 Carlos Alberto Lopez Perez 2017-01-17 03:21:25 PST
(In reply to comment #3)
> The reason why all these imported/w3c/web-platform-tests/media-source tests
> should be skipped is explained in
> https://bugs.webkit.org/attachment.cgi?id=297003&action=diff (line 234):
> "Webm is required by the tests but we don't support it."
> 
> Please, skip these tests again until webm support is enabled.

Of those 54 tests there are 18 passing (even without webm support). How is that?

Also I don't think skipping tests is the best idea. If you skip tests you pretty much don't have any coverage regarding them. You will miss any revision causing them to suddenly crash or timeout. By marking them as failing or crashing you get basic test coverage for them even when they are still not working or the feature is still not 100% implemented.
Comment 5 Carlos Garcia Campos 2017-05-08 02:35:14 PDT
This no longer crashes, but fails since we upgraded to GST 1.10.4, see bug #171726
Comment 6 Carlos Alberto Lopez Perez 2017-05-08 07:06:25 PDT
This bug shouldn't be closed.

There are still many tests pointing here in LayoutTests/platform/gtk/TestExpectations
Comment 7 Carlos Alberto Lopez Perez 2017-05-08 07:07:16 PDT
(In reply to Carlos Alberto Lopez Perez from comment #6)
> This bug shouldn't be closed.
> 
> There are still many tests pointing here in
> LayoutTests/platform/gtk/TestExpectations

Sorry.. i cunfused the last digit of the bug