Bug 167035

Summary: Web Inspector: no way to filter out all console messages or all evaluations/results
Product: WebKit Reporter: Blaze Burg <bburg>
Component: Web InspectorAssignee: Devin Rousso <hi>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, ews-watchlist, hi, inspector-bugzilla-changes, joepeck, rniwa, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
See Also: https://bugs.webkit.org/show_bug.cgi?id=201060
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Archive of layout-test-results from ews104 for mac-highsierra-wk2
none
[Image] After Patch is applied (Light)
none
[Image] After Patch is applied (Dark) none

Blaze Burg
Reported 2017-01-13 17:00:12 PST
Sometimes a webpage is very spammy with logs, and there's no obvious way (aside from entering jibberish into the filter bar) to hide all console messages from the inspected web content. Xcode has two sides in the area where the Split Console is, which they call the Debugger Area. You can switch between showing logging and a prompt side-by-side, or just one or the other. I don't really like this UI since it's hard to read both of them when split. Perhaps just having a drop-down or scope bar on the left side of the split console navigation bar would be sufficient for turning one or the other off.
Attachments
Patch (9.66 KB, patch)
2019-02-14 15:34 PST, Devin Rousso
no flags
Patch (10.84 KB, patch)
2019-02-24 20:00 PST, Devin Rousso
no flags
Patch (10.94 KB, patch)
2019-03-20 11:55 PDT, Devin Rousso
no flags
Archive of layout-test-results from ews104 for mac-highsierra-wk2 (2.92 MB, application/zip)
2019-03-20 15:34 PDT, EWS Watchlist
no flags
[Image] After Patch is applied (Light) (603.86 KB, image/png)
2019-03-20 16:26 PDT, Devin Rousso
no flags
[Image] After Patch is applied (Dark) (617.87 KB, image/png)
2019-03-20 16:26 PDT, Devin Rousso
no flags
Radar WebKit Bug Importer
Comment 1 2017-01-13 17:01:10 PST
Devin Rousso
Comment 2 2019-02-14 15:34:56 PST
Joseph Pecoraro
Comment 3 2019-02-18 11:42:32 PST
Comment on attachment 362071 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=362071&action=review > Source/WebInspectorUI/UserInterface/Views/LogContentView.js:78 > + new WI.ScopeBarItem(WI.LogContentView.Scopes.Console, WI.UIString("Console"), {className: "console"}), Console sounds more like `console` to me then the Web Inspector Quick Console.
Devin Rousso
Comment 4 2019-02-18 11:45:45 PST
Comment on attachment 362071 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=362071&action=review >> Source/WebInspectorUI/UserInterface/Views/LogContentView.js:78 >> + new WI.ScopeBarItem(WI.LogContentView.Scopes.Console, WI.UIString("Console"), {className: "console"}), > > Console sounds more like `console` to me then the Web Inspector Quick Console. I'm not entirely sure what you mean by that? This patch isn't specific to the quick console. It's about providing a way to filter commands/results entered into the console.
Joseph Pecoraro
Comment 5 2019-02-18 12:12:13 PST
(In reply to Devin Rousso from comment #4) > Comment on attachment 362071 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=362071&action=review > > >> Source/WebInspectorUI/UserInterface/Views/LogContentView.js:78 > >> + new WI.ScopeBarItem(WI.LogContentView.Scopes.Console, WI.UIString("Console"), {className: "console"}), > > > > Console sounds more like `console` to me then the Web Inspector Quick Console. > > I'm not entirely sure what you mean by that? This patch isn't specific to > the quick console. It's about providing a way to filter commands/results > entered into the console. "entered into the console" that is the Web Inspector Quick Console, no?
Devin Rousso
Comment 6 2019-02-18 13:12:51 PST
Comment on attachment 362071 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=362071&action=review >>>> Source/WebInspectorUI/UserInterface/Views/LogContentView.js:78 >>>> + new WI.ScopeBarItem(WI.LogContentView.Scopes.Console, WI.UIString("Console"), {className: "console"}), >>> >>> Console sounds more like `console` to me then the Web Inspector Quick Console. >> >> I'm not entirely sure what you mean by that? This patch isn't specific to the quick console. It's about providing a way to filter commands/results entered into the console. > > "entered into the console" that is the Web Inspector Quick Console, no? Oooohhh. I misunderstood what you were saying. Yes, I am not entirely set on using "Console", as it's not really that clear. Perhaps we could use "Inspector", or "Developer"? I'd like some sort of name that clarifies that the filtering is based on commands/results entered by a developer (manually) into Web Inspector's Console tab/prompt.
Joseph Pecoraro
Comment 7 2019-02-18 15:05:10 PST
> Yes, I am not entirely set on using "Console", as it's not really that > clear. Perhaps we could use "Inspector", or "Developer"? I'd like some > sort of name that clarifies that the filtering is based on commands/results > entered by a developer (manually) into Web Inspector's Console tab/prompt. I like: "Prompt" "Console Prompt" "Inspector" Some I like that aren't colloquial enough: "Quick Console" "REPL" "DevTools"
Devin Rousso
Comment 8 2019-02-24 20:00:46 PST
Timothy Hatcher
Comment 9 2019-03-20 09:26:30 PDT
Comment on attachment 362876 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=362876&action=review I like this, but it should be called Evaluations. > Source/WebInspectorUI/UserInterface/Views/LogContentView.js:87 > + new WI.ScopeBarItem(WI.LogContentView.Scopes.Prompt, WI.UIString("Prompt"), {className: "prompt"}), Evaluations?
Timothy Hatcher
Comment 10 2019-03-20 09:27:06 PDT
Comment on attachment 362876 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=362876&action=review >> Source/WebInspectorUI/UserInterface/Views/LogContentView.js:87 >> + new WI.ScopeBarItem(WI.LogContentView.Scopes.Prompt, WI.UIString("Prompt"), {className: "prompt"}), > > Evaluations? Since the others are plural.
Devin Rousso
Comment 11 2019-03-20 11:55:47 PDT
Timothy Hatcher
Comment 12 2019-03-20 12:48:48 PDT
Comment on attachment 365375 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=365375&action=review > Source/WebInspectorUI/UserInterface/Views/LogContentView.css:46 > + background-color: darkgrey; Does this need a dark mode color? Normally we don't use names unless it is white, black or transparent.
EWS Watchlist
Comment 13 2019-03-20 15:34:13 PDT Comment hidden (obsolete)
EWS Watchlist
Comment 14 2019-03-20 15:34:15 PDT Comment hidden (obsolete)
Devin Rousso
Comment 15 2019-03-20 15:41:18 PDT
Comment on attachment 365375 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=365375&action=review >> Source/WebInspectorUI/UserInterface/Views/LogContentView.css:46 >> + background-color: darkgrey; > > Does this need a dark mode color? Normally we don't use names unless it is white, black or transparent. It looked fine to me in dark mode. We've used variations of grey as both light and dark before. I'll upload a screenshot of it.
Devin Rousso
Comment 16 2019-03-20 16:26:10 PDT
Created attachment 365429 [details] [Image] After Patch is applied (Light)
Devin Rousso
Comment 17 2019-03-20 16:26:22 PDT
Created attachment 365431 [details] [Image] After Patch is applied (Dark)
WebKit Commit Bot
Comment 18 2019-03-20 16:53:09 PDT
Comment on attachment 365375 [details] Patch Clearing flags on attachment: 365375 Committed r243260: <https://trac.webkit.org/changeset/243260>
WebKit Commit Bot
Comment 19 2019-03-20 16:53:10 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.